Wireless Firmware update interrupted, What next?

While updating My Passport Wireless 2 TB firmware the process was interrupted - or never finished. (How long should this take?) What are the next steps to take? The Community seemed to indicate a reset, so tried that. It does not help. When I connect by USB, I receive an error: There is a problem with this site. Scan and fix it.
I’m using Windows 8.

Using File Manager, I can see initial files and folders. I have tried a manual Firmware update, but nothing happens.

Follow the directions for downloading the firmware, placing it on an SD card correctly so it will be updated when you put the SD card in and turn on MPW. The instructions for doing this are all explained in the complete user manual which you have already downloaded from WD Support. Right?

This is the way I have always updated mine. Updating wirelessly can be risky as you have found. If the SD card method does not work, then I suggest you contact WD directly

Also, if you did not find exacting directions for resetting back to factory defaults, let me know. In the case of failed firmware upgrades, the device has a very basic firmware in it that will be installed during restore to get things up and running again. BUT, you will then need to install the current firmware.

I have posted exact directions for restore to defaults a few places on this fMPW orum, but the user manual has the same basic instructions, too.

I had performed factory reset. Could not connect to anything due to lack of firmware. I used the “My Passport Wireless User Manual” to search for updating firmware using SD card. Could not find anything.
On the WD web site I found


This provided clear instructions for updating the firmware. Especially helpful was information regarding the LED lights. The update only took a few minutes. Never got around to timing it. I think things are working now. Thank you. J

Glad it’s all working for you now.