WD TV Live cant access shares on XP based PC

There is already a ton of info on this board. I have been working on this for a few days with no luck.

Here is where I am so far:

  • Purchased 1 week ago, never has connected to shares
  • Works with Netgear N600 router to use service from Netflix
  • I have attempted the TonyPH12345 troubleshooting guide but wihtout success. The first command from my computer does not see other network devices as in his example.
  • I enabled/started the Network DDE and DDE DSDM services
  • I enabled NetBIOS over TCP/IP
  • Renamed my MSHOME group (default on new router) to WORKGROUP to match the WD TV LIVE box.
  • rebooted, restarted, reset to factory settings etc.

I am using Win XP Pro on a relatively old (2004) machine. The network router is also brand new, bought with the WD Box. I can muddle through instructions that I have read through this site (tremendous help available by the way) but I am by no means a networking expert. I attempted using my work laptop to access network shares but was also unable. I believe the issue is my PC, not the box, but this is the very capability I bought it for. I read another thread about exceptions in the firewall. In order to test it, I disabled the firewall completely and still no luck. I re-enabled for security.

Please help. My thanks in advance.


New symptom. I get a system error 6118. Looks like some ports are closed that need to be opened thru the firewall. I’ll search for some info on this and report back.

I’m losing hair over this. I want this to work. Please help.

From the TonyPH12345 tutorial:

Results of net view are only sees my pc, not the WD TV Live or the WD Live book I bought today. Discover won’t see it either.

Results of nbtstat -a <>

which makes me think the master browser is working correct?

I enabled NetBIOS over TCP/IP

I opened all the ports (correctly I hope)

I’m near done.

if anyone has anothe clue, please help.


Working great now. Streams from wireless source, but not as originally planned. I never have gotten it to see the network shared folders on my PC. I even boxed it all back up Friday and took it back to Best Buy to get an Apple router and Apple TV2. They were out of Apple.

So instead, I bought a 2TB NAS, another  WD product. Plugged it in and hooked up to the router switch. At this point the TV Live can see the NAS, but not the PC, and the PC can’t see either so I’m still stuck. Geek Squad is clueless, WD phone help has their “system down” and I’m on the brink of a meltdown. My brother (network admin professional) then tells me to link to the NAS by IP address. How do you do that I ask. Get the IP from the router (already knew that) type it into the address bar in “my computer”. I didn’t know you could do that I say. At this point I can see the NAS from the computer (opened up a Firefox browser) but still not from windows explorer. Then he had me Map a Network drive to the already available public shares directory that I could see on the NAS through Firefox. I mapped the drive to ///Public and viola I’m hooked up. Now I copy the data to the NAS from the PC and it streams seamlessly to the TV Live box. I bet I could even hook the Live box to the XP network shares now by mapping it as a drive, but that would just clutter the UI on the TV screen and I don’t need it now.

The box seems to like .avi and .mkv the best. It hangs up on .mp4 which locks up the box from playing anything until you un-plug and re-boot. So I avoid mp4’s and no problem.

I also believe this would have been an easy process with Windows7.