WD TV Live - Cannot see network shares

Hiya, hope someone can help me with this.

First my setup: Windows XP pc with shared folders

2 Network cards in PC (one with cable to router/cable modem for internet, other one has cable to WD TV)


Due to this setup I have 2 subnets.

My WDTV can see the internet fine and have tested it by streaming youtube videos but I cannot see or connect to any network shares. Previously I had a Gen 1 xbox running xbmc on the network cable which I have now unplugged and put the WD TV live in its place. The xbox could connect to the shares and stream with no problems and still does if I plug it in again. So I know my browser service is active on the pc, the shares on the PC are setup correctly and I have triple checked that the workgroup names are the same

. So knowing the internet works and I can ping the WD TV box ok, I am now stumped as to what the problem could be. Any ideas?

Have also tried running a network cable from the WD TV straight to the cable mode/hub, which the pc also connects too.  Internet streaming works, I can ping the WD TV from my pc, but the WDTV will still not see my shares.

Firewall is off.

net view shows the shares etc.


After writing the above I checked net view again and it showed the wdtv in the list this time…checked shares and they work now.  So looking good!

Wondering if the first time it looks for shares it takes a long time to enumerate?

It should not take that long to recognize the shares, but if it’s already working, cool.