WD TV Live after 1 year turned to pink screen and no audio gets from hdmi

I have a WDBGXT0000NBK-12 a WD Tv Liver bought more or less 1 year ago.

It is connected from the very beginning to a Samsung TV UE39EH5003 through the HDMI channel.

It was perfect in audio and video.

Two days ago it suddenly turned the screen to pink and no more audio gets out from the hdmi source, whatever I play.

Though I change video settings, temporary fixing the pink issue, the WD not never keep the changed settings anymore. And anyway no way the audio plays anymore.

On the other hand on the same channel HDMI the DB-player works still perfectly.

I tried to go back from the latest firmware (2.02.32) to the previous and though the pink screen seems to disappear, no way to have settings changes kept and no way to have audio back.

There was the same issue posted here  http://community.wd.com/t5/WD-TV-Live-Live-Plus/Keep-getting-Pink-screen-all-the-time/td-p/536495 but it looks like WD didn’t care to solve the problem.

It’s clear that a solution, whatever, is absolutely due by WD.


Hi and welcome to the WD community.

Try to use a different HDMI cable on the unit and see if you get the same issue. Also if possible check if you can use the same HDMI cable on a different TV.

Hope this helps you out.

i have used two different cables on both the hdmi Tv inputs.
The main problem is that wd doesn’t hand-shake properly and though i force configuration (audio video) wd tv live doesn’t care and changes are immediately lost.

have you tried the ‘Auto’ setting ?   ie. Setup > Audio/Video Output > Video Output > HDMI > Auto    :neutral_face:

Yes. The auto-setting always chooses the setup that gives no audio, sometimes chooses the setup that gives pink video and sometimes the correct setup for video.

It’s quite strange.

Anyway I tried also the HDMI connection (same cable) to a different TV (a philips) and this time the auto-negotiation works.

Despite this, also with the Philips connected still WD Tv Live doesn’t accept any manual configuration change, which is discarded as soon as I set it. 

So … summarizing:

  • my TV (a Samsung) was subject to NO changes for what I know (and still perfectly works with the BD player by using the same cable and the same HMDI inputs) but WD changed it’s behaviour, wich is unstable, with firmwares from 1.15.10 to 2.2.32 especially with the audio (no audio).

  • WD seems to correctly negotiate, by using the same HDMI cable, with a different TV, including audio

I’m going to try to figure out if previous WD firmwares fix the problem … I’ll update you, but any suggestion on what to do and how to understand the problem source, are very welcome. 

PS: I’m sure Samsung TV firmware was not updated: latest release is T-NVTE4DEUC-1018.0 (2014.11.04) while mine is 1008.0.

The fix is usually turn off TV, leaving WDTV on, then after TV is completely off, turn it on.

I had exactly the same problem some time ago.  I was using an ‘adapter’ (HDMI to DVI) to fit the back of an older plasma TV.  As soon as I bought a decent HDMI/DVI adapter the problem was fixed.

I would be trying a different HDMI input on your TV.

But I guess you have tried that.