WD SN750 SE write speed at 60MB/s

I just bought this SSD SN750SE 1TB a month ago.
I have two issues with this thing.

  • The SLC cache is unpredictable. On almost empty 1TB drive, the SLC cache is sometimes around 1GB, other times it’s > 8GB.

  • The sustained write speed drops below 60MB/s. When it’s out of SLC cache, the write speed drops to almost 0MB/s, but the Windows Explorer will show it has 60MB/s.

I saw on Amazon reviews that other people are having same issues.

Is there a way to improve/fix this issue?

The computer is an Acer Aspire 5 laptop with i5-10210u processor.
The NVME interface is Gen3.
When I run benchmark, I get advertised speed OK. (something like 3000MB/s read, 1100MB/write)

The test is copying 8GB file from the same directory.
The highest speed is around 500MB/s? The lowest is almost 0MB/s.

Also, with another SSD (WD Blue 1TB 3D NAND SATA) on the same laptop, the minimum speed is consistent and > 250MB/s.



I did many testing for days and I found the solution - don’t do test.

Here are some things I found though from my testings:

  • The minimum write speed of SN750SE is 175 MB/s. You have to turn off the Windows write cache to see this speed. (Do it from WD dashboard) I’m guessing SN750SE is a QLC device.

  • The static SLC cache is around 1GB.

  • The seq write benchmark without cache is around 800MB/s. (1GB data file size. That includes SLC cache effect)

  • The seq write speed of 2800MB/s is with write cache enabled.

  • After filling the entire SSD for a test (and erasing to empty again), the benchmark write speed dropped to 800MB/s even with write cache enabled. I tried giving the drive more time for TRIM, manual TRIM and all that. It didn’t help. There are many articles reporting this issue with WD SSDs (like SN850). The only way to recover is to do secure erase on the entire drive. (PartitionMagic, write 0’s. – not 1’s) So, I backed up the drive, did secure erase using 0’s, ran the benchmark, it’s 2800MB/s, good, restored the content, it’s still 2800MB/s. good.)

And I’m not touching it any further from here. The more I use it, the more broken it becomes.

And don’t forget, WD SSDs suffer from ‘bit rot’ – I found this while I was copying content from my old WD SSD. The read speed was like 1MB/s or lower. Your months old data becomes so hard to read, the read speed just crawls at 1MB/s. I used ‘diskfresh’ tool to rewrite the whole drive and the read speed is reasonably fast again.

So, bottom line :

  • Don’t do tests on WD drives. You’ll get disappointed.
  • I’m ready to do backup - secure erase - restore the entire drive when needed, to restore write speed.
  • I’m ready to do ‘diskfresh’ on monthly basis to restore the read speed.

And, the 60MB/s … the internet says, it could happen when you write beyond SLC cache size and your sustained write collide with SLC cache flushing - so, with 175 MB/s sustained writing, you get 60MB/s, the SLC cache flushing gets 115 MB/s…

I have the same issue, but shouldnt the slc cache flush or reset? i get 3400mb/s speed but after abit it just gets stuck at 800mb/s only after restarting the pc the speed goes back up to 3400mb/s. is this normal? i dont know that much about ssds thanks for the help.

The write speeds should be higher than that. WD SN750 SE 1TB NVMe SSD Review PCIe Gen4-ish - Page 3 of 3 - ServeTheHome

i think you missed my point. the ssd’s speed gets capped at 800mb/s after normal use and it doesnt go back to the slc spped which is the 3600mb/s this is with normal use not transferring files, and my question is shouldnt the ssd go back to the 3600mb/s speed? i get these speed with crystaldiskmark