WD Green Writing Speed Problem?


#1

I have WD Green 120GB product. The box says 430MB writing but I am getting 110MB writing. What is the problem ?

Laptop: http://www.toshiba-turkey.com/discontinued-products/satellite-l750-1xt/

dfhdg2


#2

Sorry. I don’t have anything to add. I just made an account and can’t create a new thread so I’m checking to see if I can at least reply to a comment,


#3

I am having the EXACT same issue on my PC.
MSI H110M-PRO VD motherboard
Pentium G4400
WD Green 120 GB SSD.

I also tried installing the Intel RST driver but nothing changed.
Capture


#4

Biostar BT250 BTC
Pentium G4400 WD Green 120 GB SSD
windows 10


#5

Hi All,

We did not publish the write speed on this product, however based on my experience the performance you are seeing is not normal. Please contact our support center to go through some troubleshooting steps and determine if the product will need to be replaced or not.


#6

my WD SSD may be something wrong!

1

please tell me how to check my SSD status,


#7

You can install WD SSD Dashboard to check SMART attribute for the SSD, however in your case I think you can contact WD support and check for warranty replacement


#8

I checked SMART that said that there was no problem, my SSD is alright!
but SSD speed very low.


#9

My new ssd green 120g

https://drive.google.com/open?id=1lx-vhs5vx5uU20lAvcl6Ji9cYq_hfMbR


#11

The WD green ssd is a DRMA-less SSD. It uses a small SLC buffer for higher write performance. Once that is exhausted it falls back to the TLC nand for writes. With the 120GB capacity the SLC buffer is pretty small. In the test most all of you are using 1GB transfers with 5 passes. this means you are effectively writing 5GB of data. this is most likely exceeding the size of the SLC buffer and may be why the write speeds look so slow.

I would try changing crystal disk mark’s settings to something like 1GB transfer size and 1 pass. Give the SSD some idle time to clear the SLC cache then do the benchmark again. This time if the SLC cache is clear and the transfer size will fit in the SLC you should see the advertised write speed.


#13

Heres a spanner in the works, I have exactly the same problem on the 240gb model. Slow write speeds.
BUT, take the drive out and put it in a machine with windows already installed, diskpart and clean the drive, then run atto on it again, you will get a full 450MB/s write. Any ideas? Only seems to happen if windows is installed on it :confused:


#14

The technical service has detected that the product is defective. They will return because they have no similarities on their hands. service in Turkey, were sent by courier without giving me any information. I will recommend Sandisk SSD to you and I will recommend it to you.

Product number: 172938801 …
Material Code: WDS120G1G0A

Note: If you have the same serial number, return it to you.

I used translation :slight_smile:


#15

I just bought WDS120G2G0A, have the same problem
crystaldiskmark 1cylce, seq read and write results:
100MiB = R 473 ; W 293
500MiB = R 483 ; W 123
1GiB = R 496 ; W 90
2GiB = R 487 ; W 92

so this is normal? when we test with large file, SLC buffer can’t handle large file ?

Use Windows 10 x64 1709

------- update 1---------
I back to the store I bought yesterday, they replace with new one, still WDS120G2G0A
Then I benchmark it, seq R 500MB, W 230MB

but after few usage and data written (install windows in it), seq W drop again to 70-90MB/s
I tried format the ssd, and boot use other windows partition, then benchmark again the ssd, seq W still 70-90

Then I try the ssd on my win 7 notebook with 2.5" enclosure USB 3.0, write speed still 70-90MB/s

2 same ssd with same results, low Write speed ???

408051_20180206073904


#16

The same disk and the same problem. Read 450-520 MB / s, Write 60-80 MB / s. It is normal? Help the new firmware? Thanks


#17

I have same disk (WDS120G2G0A) with similar problem. Any official stand of WD? Are 60-80 MB/s write speed normal or defective? Also, random 4k read speeds also look slow.

SSD p


#18

Hi, have you ever found a solution? Thx


#19

Yeah but TLC NAND should not make a SSD perform slower than my 13 year old dying hard drive…
wtf, samsung ssds have the same RAM cache , but even when their cache runs out off space . it still holds speeds off 500MB/S

hmmmm this is making me rethink, if a ssd is going to be this slow i may aswell just get a real fast WD RED/GOLD and use them in RAID


#20

Hey I am having the same SSD WD Green (WDS120G1G0A)
On my macbook pro and I am only getting 100mbps of write speed I just bought it, it’s fully empty except the OS.
(BTW Trim is enabled )
What to Do???


#21

I have 3 ssds, of the model (WDS120G2G0A). Tests with 1 ssd and raid0 with 2 and 3 ssds.


#22

I have a WD Green 120GB and the same thing happens to me.
Anyone found the solution?

Captura2