WD Scorpio Blue in Acer Aspire One doesn't boot


I have a problem with my WD Scorpio Blue 320 GB hard drive (WD3200BPVT) in Acer Aspire One (722-C62RR). When I turn on my computer, I got the message that the disk is not bootable thus the system won’t load. I have done many different things to solve this issue and finally I recognized it as (probably) cyclic redundancy check error. At first, I tried to recover my data, but now I’m only trying to format this disk and install new OS, but still I can’t do it. Here are steps I’ve already done, which didn’t really help:

  1. Disk was disconnected from the notebook and connected again several times, in order to make sure that it’s done properly. Didn’t help.

  2. I tried to boot with wireless network adapter disconnected, because I thought that might cause the problem. Didn’t help.

  3. I changed boot options in BIOS and tried probably every possible configuration. None of them helped.

  4. I tried to boot from Acer recovery partition, in order to simply reinstall the OS or access command line and fix partitions from there. However, recovery partition, as well as the others, wasn’t found, I couldn’t boot with anything from that disk.

  5. I booted from GParted Live USB on my Acer notebook. It worked, I was able to browse devices from there, but it couldn’t find the hard drive. The only drive I could access and manage was pendrive, on which GParted was installed.

At this point, I bought adapter, which allowed me to connect the hard drive via USB to another computer. Finally the disk was kind of alive. So following steps were made with hard drive connected with my 2nd notebook via USB adapter.

  1. I connected the disk through adapter to another notebook, with Windows 7 on board. It recognized the device and installed some default drivers, but didn’t show up in explorer.

  2. I downloaded some WD software from your website. Western Digital Data LifeGuard Diagnostic tool (WinDlg) was first. It does see the disk, however it’s capacity and other properties are unknown. It can perform both quick and extended test on it, and all of them are passed with no probem. The thing is, that it assumes, that the disk’s capacity is equal 0, so I suppose, the tests are not really done at all. Writing zeros also works fine, but takes around 0 seconds and changes nothing.

  3. Secondly, I tried Acronis True Image WD Edition, also downloaded from WD website. Well, it did even less for me, since it didn’t even see this damaged hard drive, and some options, which might be useful, are disabled for this free, trial version.

  4. Finally I tried HD Tune. It had the best results so far, since it could recognize the disk and even said it’s capacity correctly. All space was unallocated. It could also run some tests and write zeros to the disk in several ways, but everything failed. For example, writing zeros took around 30 seconds and ended up with 2500 errors.

  5. Windows Disk Management program also recognized the disk and showed it as offline and 320 GB with all space unallocated. I could browse it’s properties, but when I tried to bring it online, it was the first time it threw “cyclic redundancy check” error.

  6. From this point, I took the keyboard and started working on command line in elevated mode. WMIC program with DISKDRIVE option applied showed the disk with proper label and capacity, but with unknown number of partitions, so it didn’t help too much.

  7. DISKPART program also saw the disk (command: list disk) and allowed me to select it (command: select disk 1). When I tried to bring it online (command: online disk), surprisingly, it said the disk is already online, but when I attempted to clean it (command: clean), it also threw “cyclic redundacy check” error.

  8. I think, that it’s important to mention here, that I did number of similar attempts with DISKPART program and sometimes it couldn’t see the disk. I had to search for it (command: rescan) several times, or even reconnect it to the notebook, to be able to see it again. All this time, Windows Disk Management saw and recognized the disk.

  9. I knew that CHKDSK program is dealing with CRC errors, but I couldn’t run it on physical disk with no assigned letter. I tried to mount in in some ways (via Windows Disk Management tool and mountvol command from command line), but none of them did the job.

  10. I found out that CHKDSK can take as an paremeter not only drive letter, but also hardware GUID (as I suppose). I confirmed it by mounting recovery partition on that 2nd notebook to letter W, so I decided to give it a try. I could find this GUID in disk’s properties, but CHKDSK didn’t accept it, thus didn’t enable me to perform disk check.

This is pretty much everything I did. I write this as I ran out of ideas. I’m googling how to fix CRC error and every solution I’ve found either assumes that I can somehow access the drive or doesn’t work for me. So I would be grateful for any smallest hint, which is not something I’ve already done, because all of these above didn’t help.

Edit: Oh, and I didn’t mention imporant thing: when I connect the disk via this USB adapter, I can see green diode light and I can hear it spinning.



Why d on’t you replace the drive?