Caviar Blue WD3200AAJB (EIDE) half dead?


#1

Ok, let me begin by saying that I spent an entire day trying every troubleshooting method and option to get this working.

I purchased this HD in september.  I installed windows XP on it, and everything ran beautifully for about a month.  Upon restarting my computer, I receive the dreaded “Disk Read Error, press ctrl+alt+del to restart” message.  I tried various quick fixes, and even tried running the WD3200 as a slave, but no matter what configuration I tried, I got the disk read error even when I was trying to boot from my working drive.  I was short on spare time then, so I reverted back to an old 100gb 5400 WD that I’ve had for about 6 years now, even though it’s probably about to give out.

Yesterday, I worked up the nerve to try and diagnose/fix the problem.  Here is what I did:

*note, I got the drive to run as a slave and was able to see it in XP SP3, however it only showed 128gb (even in my bios).  I did all of this in a master/slave setup using my old 100gb as the master and the new WD3200 as a slave so I could continually check the internet for new solutions.  I changed the boot priority in my BIOS to check after each attempt to fix.

First, I was confused that it only recognized 128gb.  I went to disk management, and it only showed the 128gb there as well…  no way to extend the partition because it showed no unallocated space.  Hmm.  So, I download partition magic and have the same problem…  it isn’t showing any unused space.  I made sure that my registry had support for large hard drives enabled (it did) and I have SP3 so I know I wasn’t restricted because of that…  besides, it was working fine before.  I flashed my bios with the latest update just for the **bleep** of it, even though I knew my current bios supported over 137gb HDs.

I booted to the Windows Recovery Console and ran chkdsk /p /r.  Everything went fine.  I restarted, and received the same error.  I ran fixboot and restarted, and no change.  I ran fixmbr and received the caution message, but ran anyways because I no longer care about the data on the drive.  THIS time, when I restarted and tried to boot from the WD3200, I received the message “Invalid Partition Table”.  Ok, at least something has changed, and I assume it’s because I ran fixmbr.  NOW, my bios is showing the entire hard drive.

I used disk management to format (NTFS) the available 128gb, and I AM able to put data in that space.

I downloaded the WD Data Lifeguard Diagnostics software for windows, and ran the quick and extended tests, and everything checks out.  I still only see 128gb of available space in disk management AND Partition Magic.  I do, however, see 320gb of space in the WD DLD software.  I also see 320gb of space available in Partition Table Doctor, but am unable to do anything with it in that program.  I changed the jumper to cable select, but everything is exactly the same.

So, my last attempt to fix the problem was to completely zero out the drive using the Data Lifeguard Diagnostics software (windows version).  It gets about half way through (probably to the unused sectors that windows can’t see) and my computer locks up.  I tried it again for good measure, and it locks up at the same spot.

Does this mean those sectors are damaged and completely unusable no matter what I do?  Is this hard drive destined to be 128gb?  Is there anything else I could try?  I’d appreciate any help…  ultimately I want to boot from this drive using XP because it’s higher RPM than my old drive (which is just about dead).


#2

I fixed it…  I had to do a DoD level wipe, and then use the windows install CD to format the drive from dos.  You can close this thread or keep it for future reference.