WD Photo's Update... Iphone

Just updated my WD Photo app on my iphone after it said i could now send items from my phone to the WD Live HD.  

Just tried to follow the promps… looking for the camera icon to upload to the HD.  Unfortunately there is no camera icon on the application.  

Any1 else having the same issue?  Does the HD have to be updated?


Have the same issue. There is no camera icon at all. I am also upset that this is a network drive but I can’t access on my iPhone with this app for other or all files. Photos are great but sometimes I need to see files which is the reason I bought the drive. Make the app work for all files on drive not just photos .

Yeah. It definitely doesn’t work. What a disappointment.

There is a firmware update being pushed for My Book Live that you will need to accept before the camera icon shows up. It uses a new service called wd 2go. If you are using the MioNet service you will not be able to upload. The primary reason is the wd 2go can communicate peer to peer with your iPhone / Android WD Photos app allowing you to push large videos in your local area network directly to your MBL. WD TV already does this as it never used MioNet.

After you accept the firmware, you will need add a new device (select MBL). It will ask you for an activation code (click the Guide Me button in the upper right hand corner which shows you how to get the code from the MBL). The new MBL will then have the camera upload button. Videos go into Shared Videos/your phone name and photos in Shared Pictures/your phone name.

Note: After upgrade, if you were using MioNet the old drive under mionet will no longer work - so either logout or remove that drive from MioNet (if you still want to use MioNet for the older drives such as My Book World Edition).

Hope this helps.

Does it work on IPad?


I updated my firfirmware for MBL today and dont see the option to generate Activation Code anymore! Under Settings-> Remote Access - there’s only 2 accordians available: ‘WD Photos’ and ‘MIONet’. How do I get the activation code ??

Seems like there was an issue upgrading the firmware - the updates tab showed correct upgrade time - but the older version of MBL. Repeating the upgrade solved the issue with the code and access - but now the light in the front og MBL has gone forever it seems :slight_smile: Should I be worried about the light? The HD seems to be working good - but there is no light after the upgrade.