WD Photos App requesting Firmware update, but everything is already updated

When using the WD Photo app, the MyBook Live device appears but states “No Photos Found” , “Network drive firmware update required to support this version of WD Photos.  Go to wdc.com support for information”

I have confirmed through the MyBook Live dashboard that all firmware is up to date.  Tried re-booting PC, re-booting MyBook Live, re-installing WD Photo app on iPhone, but still no photos.  

I am running WD Photos (ver 1.1.1) on iPhone4 (OS 4.2.1), and MioNet 4.2.27 for our MyBook Live.  Everything is connected at home, MioNet sees the drive resource, no problems on home networking.

Help or suggestions from WD appreciated. 

I am having exactly the same problem, and support has not yet been helpful.  Please keep me in the loop if you find a solution.  Thanks.

same issue but with iPad. Calls for “network drive firmware update required to support this version of WD Photos” . Firmware for brand new My Book Live is current. Any help?

Exactly same for me… Jan 3, 2011… No luck yet, keep us posted if you find anything.

We released a new version of MioNet for the My Book Live a few days ago that should have resolved this issue. If you are still experiencing the issue, please send me an IM so we can setup a troubleshooting session. Please provide your phone number and E-Mail address, as well as your time-zone and hours/days of availability.

Hi Laura,

It is not readily apparent to me how to upgrade the MioNet software on my My Book Live.  I went to the dashboard page and found Updates.  It listed my Firmware version as 01.02.03 and my MioNet software version as 4.3.1.12.  I clicked “check for updates” and it responded that the “frmware was up to date” but didn’t gove me a separate option for updating the MioNet software.  Naturally, my questions are twofold:

  1. What is the latest version of the MioNet which I need to have running on the My Book Live?

  2. How do I install it given that the update seuqence I tried above did not update the MioNet to the version you said was just released.

FYI, I am able to access the files on my My Book Live via the MioNet web interface without issue.

Thanks for your help.  This has been a very disheartening experience so far.

~Nolan

Nolan,

  MioNet actually automatically updates itself when an update is available, provided the drive has Internet access. 4.3.1.12 is the latest version for the My Book Live. Is the WD Photos app still requesting a firmware update after clearing the cache on the app?

I have the same problem

no photos found

firmware Version 01.02.06 with MioNet 4.3.1.7

reinstalled iphone app wd photo (version1.1.1)

nothing :frowning:

Sorry, forgot to say My Book World Edition.

Iphone 3gs running version 4.2.1

Solved by putting photos in to drive Public and directory Shared Pictures (I had wrongly assumed it would pick them from the whole drive.

Then I deleted the app and reinsatalled :slight_smile:

Funky app, its the way forward!

Hi Laura,

I reinstalled the WD Photos app today, and also went to the settings panel and checked “Clear Cache on Next Launch”, both to no avail.   See iPhone 4 screenshot attached.  As I said, the files are accessible via the MioNet web interface.

What do you recommend as next steps?

~Nolan

Firmware Error