WD PHOTOS never show photos anymore

I’ve had my WD My Cloud drive for a while and it’s always worked well until lately.

Had 20,000+ pictures on it and used WD Photos on my Iphone and Ipad to access these photos but now they started to not show the thumbnails and photos, so i rebuilt the media database, turned off remote access, and back on, reset the cache, everything I could find to try and fix the situation and was told by support that it could take along time to rebuild these thumbnails.

So I moved all the photos except 13 off the server and yet WD Photos still does not work. See the screen shots.

Anyone else have this issue and figured out how to fix?


Hello, have you tried the WD My Cloud app? What device do you have? What firmware you have on the My Cloud?

I have a 2TB MyCloud Server using the latest firmware v04.04.02-105

Accessing the Drive using mycloud.com from a desktop web browser does not show the thumbnails (not sure it’s suppose to) or the pictures once i click on them, but I can download the pictures once i pick “download” from the bottom right.

Using the MY Cloud Iphone app from outside my network simply does not work at all… I can’t figure that out.

Once inside my network, I can see the the pictures, once again, no thumbnails, and i can see the pictures when I click on them. When I pick pictures from the bottom, i do get an error, see below…