My Photos app not showing photos

I just purchased a 3TB My Cloud and have thousands of photos in my “Public” folder and yet the WD Photos app on both my iPhone and iPad says I have only 1 photo in that folder. As an aside, ALL of the photos appear in the iPhone/iPad My Cloud app. I’ve deleted and reinstalled the app, rebooted the My Cloud external drive, and even did a rescan, but none of it helped and I’m still not seeing the photos. Admittedly I have thousands of photos and transferred them to the drive 3 days ago. Is it possible that the app won’t show the correct pictures until the scan is completed and that it’s still doing the scan? Anyone have any thoughts?

When you look at your shares on the Dashboard are they set to Public? What share were the photos loaded to.


I have an android phone Samsung Galaxy Proclaim and when I open My Photos app I have 43 photos showing in my Public folder/share and 4037 in my Horace folder/share. Both are set for Public Access.


When I open the Public folder/share the photos are shown as two photos in Shared Pictures and 41 were uploaded from my phone to WD My Cloud by way of Google+.

All my pictures are in the Public folder and there is public access for this folder. I loaded the pictures from another external hard drive via Windows Explorer. They all appear in the My Cloud app, they just don’t appear in the My Photos app.

You said you deleted and reinstalled the My Photos app. Did you give it Cloud Access? See image below.

Yes, it does have My Cloud access and it is reflected on the Dashboard as having access. There are 50,000+ photos so could it be that it could take up to a week or so to scan and build the database? I loaded the photos about 4 days ago and as of now it is still not showing the photos.