WD Passport Unlocker not running - can’t access drive even though it’s seen in WD Discovery

I have a 1TB Passport which was encrypted with Drive Unlocker. I know I’ve changed a ton of software/settings on my computer, so I don’t know if this is a software issue, or a hardware one…

The drive spins up fine, is detected by Windows 8 on multiple PC’s (shows up as “Eject MyPassport” in the hardware/media tray icon, and makes the USB device connected successfully sound)

  • but once plugged in the Locker Auto Run won’t start and I get this blank CD drive: F that once opened I get the APPLICATION NOT FOUND ERROR.

DOES NOT show up anywhere in Windows disk management or even 3rd party partition management software (tried mini-tool) - this goes for both the drive itself and the Drive Unlocker …

So basically the Locker Error stops me to go further!

I already tried changing the path letter but still not working

In the discovery software the drive itself shows up (with no information, just a generic WD My Passport title and logo)
I’m at my wits end on this… Any help/advice will be much appreciated.

Hi @ToniDobra,

Please contact the WD Technical Support team for best assistance and troubleshooting:

1 Like

Did that, thank you :slight_smile:

Am also experiencing same issue … Any solution?

Asking them to contact support doesn’t help the rest of us. Instead, how about posting the solution publicly.