WD Passport, Help Help Help!


#1

Hi All,

Looking for a bit of assistance, I have had my passport for 2 years now, it has always work fine, but over the last few days had a number of issues, firstly having trouble connecting to any other devise, with a fast flashing white light, then when I do plug it in to anything it crashes those devises which become unresponsive until I remove the passport!!!
Sometime it does connect but getting access to all mt files on there are extremely long winded when I do. I have tried using Lifeguard, but as soon as I plug the passport in, it crashes Lifeguard!!! have also tried using a different USB connection but still no joy. Feel I am starting to run out of options now though which is why I have put this up to see if anyone can suggest anything else, as would be greatly appreciated as really don’t want to lose all the information I have on it.

Many thanks.


#2

Hi Attridge01,

You should test the drive using WD Drive Utilites. Please refer to the link given below for more information.