Problems with my pasport wireless Pro


#1

Hi

I recently bought a MPWpro. I never used it intensively yet. Just started it up and tried its functionalities.
Will be going on a trip next week, I thought to have a closer look now before I leave.

When I started it up, all the leds are blinking very fast.
Had a look in the manual what it meant, Device has a problem contact WD support

I tried pressing both buttons for 10s, nothing happens
When it is off, I tried pressing both buttons, it boots, and then blinks 1 long time, 3 short times.
I tried connecting it to my MAC, can’t even see the drive

Anyone any idea
Really could use some help, really need it next week.

Using an iMac, running sierra

thanks in advance


#2

How recently did you purchase, are you still within the return period and can return it to the place of purchase for an exchange?


#3

Bought it 17 sep 2017, had 30 days for return
It did work properly.
When I got it, I immediately configured it on my network, took some shots and dumped them on the HD, just for a try.


#4

just tried connecting it on a PC, can’t see any drive-letter


#5

Not sure this relates to your issue. In manual it states that drive is USB locked by default and won’t show when plugged into USB on pc/Mac. You can turn this off in settings by connecting via wifi.


#6

Thats the problem, cant connect through wifi either
The problem persisted, WD exchanged my HD for a new one


#7

Good to know WD support their products. Hopefully no more problems. :slight_smile:


#8

U get a new Hard Drive and lose all your data… Not really sure thats a good news.


#9

But the OP didn’t lose ALL their data, just a few test files