WD MyPassport Slim 2TB Eject not working

Hi everyone,
I bought WD MyPassport Slim 2TB few weeks ago.
Started it as it should and downloaded all 3 softwares that it supports.
Last night i have tied to Eject it by WD Discovery and got this massage -
צילום מסך 2020-11-23 024028
tried to Eject it By the windows option and got similar massage too.
I had no file opened and no software running
waited for 2 hours and it goes the same. what should i do?

Hey DahoRadle,
Sorry to hear about the issue that you are having. If you go to Settings>Device Manager>Disk Drives and right click on the drive you will see the option to Uninstall. Go ahead and select that, restart the machine, unplug your Passport during the restart while the computer is POSTing and it is safe to do so, and then plug the drive in again when you’re logged back into Windows. The drivers will automatically reinstall and (hopefully) that should fix your issue.


Hi thanks for the reply! :slight_smile:
one thing i didn’t understan dfully (eng isnt my native language)
what do you mean by that :

Daho… yes, the Safe Eject is the correct thing to do when removing a Passport device instead of just pulling on the USB connection…if something is running in the background like a movie playing or some action on a file/folder, you will definitely cause a corrupted file/folder that you may not be able to recover from. So always Safe Eject either thru the WD Apps or a right mouse click and Eject the drive from PC File Manager. However, since you get the Warning messages, you can try some other options…

  • unplug the USB cable AFTER your PC is shut down. Re-plug into PC before a Turn on.
  • if you need to Eject while your computer is On, go to Task Manager (rt click the lower tray and select TM) and End task of every WD running APP. These will re-appear after a PC restart.

OR…take a look at my reply to the past thread…on Jul 23 where I tried a permanent fix. I changed my Device Manager for the Passport to “Better Performance” from “Quick Removal” Try toggling back and forth to see what effects these changes have on your Safe Eject process. Also read some of the earlier posting in that thread or do a search in this forum for Safe Eject.

I’m really surprised that more WD users are not having issues, because they either falsely pull the plug, or they never Eject (most often on a desktop).