WD MyCloud Gen2 - Enable apps install tab + Apps!

Which latest firmware update? The one to OS5?

If one plans on upgrading to OS5 on their second gen single bay My Cloud, they should be aware they’ll likely loose the ability to enable third party apps.

Edit to add: Also note that there is no easy way to roll back to OS3. Instead one may need to use one of the various unbrick methods to push the older firmare IMG files to their respective partitions.

Well, I have already done it. The truth is, I am not using plex at all and I am updating it because of others.
I have moved my website and the statistics show me that .bin file which I repacked was downloaded 10-20x so that a very small number of people using it. Easier would be to simply show them how it’s done and stop updating the website.

I use Kodi on my Fire Stick 4K and it works amazing.

If I lose the ability, that’s fine too. I was looking anyway to upgrading my nas to support some type of raid 1 in order to get the proper backup function.

One typically won’t get RAID in any fashion on a single bay NAS unit. At most one might get some sort of software RAID on other software based NAS programs. If one wants true RAID then they’ll need to buy a multi bay NAS box.

For the single bay My Cloud the best one can do is use the Safepoint / Backup feature to back up the My Cloud contents to another drive or location. Or one can use SSH to create a script (using Rsync or similar) to copy My Cloud files/content to another location. At least one can on OS3 firmware. Not sure if this is possible anymore on OS5 firmware.

I meant as a device upgrade to something like Synology 220+ or something from WD in that price range and/or capability :slight_smile:

I need much more space than 4TB and would like a option for Raid 1 type of backup with it.

Need something with 2hdds at least.

The latest firmware is OS5? So, I have no option to see which OS do I have?

For the second generation single bay My Cloud OS5 version 5.09.115 is the latest OS5 firmware for that device.

For the OS3 firmware, the latest firmware version for the second generation single bay/single drive My Cloud is 2.41.116. In order to upgrade a second gen single bay My Cloud to OS5 one has to install OS3 firmware version 2.41.116 according to WD’s OS5 announcement.

Like always, one can see the firmware version for their single bay/single drive My Cloud version in the My Cloud Dashboard Firmware field box.

OS3 Dashboard Example:

OS5 Dashboard Example:

Thank you for detailed explanation. I am still on Firmware 2.41.116, so that means OS3 still.

For me the new way of installing app doesn’t work, but old one still does?

Firmware: 1.21.4.4079

Hi,

Does anyone know any app to record RTSP stream to MyCloud? I just want to set a separate strorage for it and let it record RTSP stream of an IP cam inside that folder only.

Thanks.

Just for test: Fox_exe file archive
If its works - i can repack all old packages to new “OS”.

1 Like

Hello all,

I’m owning a mycloud single bay gen2, just unbricked from 4 (dead HD) to 1 Tb thanks to Fox_exe method.
I just upgraded to OS5, it’s fast and, good news, the official plex apps for single bay is available on plex website.
Many thanks for your work, you helped me a lot Fox_exe and LaMpiR!

1 Like

Arcus will do this for you but idk if still activable somehow on new devices (i was having some license issue last time) and at least in my experience it was laggy and unstable

i’m going to install debian and hoping metioneye in docker will perform better

just for info, if i’ll need to replace the HD (is going to die as i’ve found it various time freezed and/or in readonly mode accessing via SSH on official firmware…) what i need to do to have a working device back? unbrick instructions? EDIT: yes unbrick instruction are enough PS. you must have an MBR partition table on the recovery USB, GPT will not work.

what will happen trying a dist full-upgrade from jessie? nvm, upgrade instruction are here Fox_exe file archive

@Fox_exe just a little typo in the Debian install how to: you are referring to a file called rootfs-jessie.tar.xz but the filename in the repo is named jessie-rootfs.tar.gz, rather than this kernel upgrade to kernel-bin_4.15.0-rc6 and dist upgrade to stretch (Dev folder) seems worked flawlessy in ~1h but after the last reboot after dist-upgrade seems mycloud password is no longer accepted seems root account have no permission to access SSH and i’m locked out :confused:

Also the (unbrick) bootable USB seems not booting, probably i need to erase again the HDD from a PC to avoid Debian from booting…

EDIT1:
Finally after, deataching HDD, booting recovery minios, reattaching HDD while powered on, and using the miniOS to mount debian root (was /dev/sdb3) and add my authorized_key i managed to login again.

PS. is normal that i still see old kernel with uname -r?
root@wdmc:/lib/modules# ls /lib/modules
4.15.0-rc6
root@wdmc:/lib/modules# uname -r
3.10.39

EDIT2: sorry going to use this post as my backlog
omv5 installation gone ok following Installation on Debian — openmediavault 6.x.y documentation just need to issue apt install postfix as it was searching for this package

also omv-extras OMV-Extras.org Plugin - Guides - openmediavault installed successfully with few plugins.

actually i’m locked on docker, installing from the OMV GUI started spamming “error” on the UI, looking at logs:

Apr 06 09:55:11 wdmc.fritz.box dockerd[14426]: time="2021-04-06T09:55:11.771765929+02:00" level=warning msg="Running iptables --wait -t nat -L -n failed with message: `iptables: Operation not supported.`, error: exit status 1"
Apr 06 09:55:12 wdmc.fritz.box dockerd[14426]: failed to start daemon: Error initializing network controller: error obtaining controller instance: failed to create NAT chain DOCKER: iptables failed: iptables -t nat -N DOCKER: ip

issued sudo update-alternatives --set iptables /usr/sbin/iptables-legacy as suggested around:

and actually i’m locked on

Apr 06 10:09:41 wdmc.fritz.box dockerd[16943]: time="2021-04-06T10:09:41.158961586+02:00" level=info msg="stopping event stream following graceful shutdown" error="<nil>" module=libcontainerd namespace=moby
Apr 06 10:09:41 wdmc.fritz.box dockerd[16943]: failed to start daemon: Error initializing network controller: error obtaining controller instance: failed to create NAT chain DOCKER: iptables failed: iptables --wait -t nat -N DOC
Apr 06 10:09:41 wdmc.fritz.box dockerd[16943]: Perhaps iptables or your kernel needs to be upgraded.
Apr 06 10:09:41 wdmc.fritz.box dockerd[16943]:  (exit status 3)

EDIT4:
ok probably i found the culprit should be the missing iptable_nat module ( missing in 4.15.0-rc6 and also 4.15.0-plus, and this plus kernel totally killed my device so i’ll restart from the rescue mode…) probably i need to recompile the kernel but the last version is from 2016 :frowning:

Transmission tested and working!

Thanks!

I have updated it to OS5. Downloaded the plex from plex website directly(OS5) for My Cloud (Single Bay). I got it installed, but not configured yet. Does it work normally on OS5 without being able to repack the file?

update
it seems so. It’s currently updating my library since I had to add everything once again. It this works, there is no need for my updates anymore.
update 2
Everything seems to be working. I don’t understand at this point why would one not upgrade to OS5 when Plex is there?

On OS5, you don’t have the Php info and PhpMyAdmin yet at least.
Can’t find a way to “re-package” or understand how to do it.
Here are the working files on OS5 for Gen2
http://anionix.ddns.net/WDMyCloud/WDMyCloud-Gen2/Apps-OS5/

How can i use the repackager?
I don’t get the instructions, i use windows, and i can use SSH on a VPS i have.

But can OS3 apps be converted into working with OS5?
Or can OS5 apps for other models work with WD Gen2 Single on OS5?

Open your VPS or create one locally. You can use ubuntu64 with Virtualbox.

  1. connect to it and create folder plex and enter it
  2. download mksapkg-64b_1.3 and rename it to mksapkg-64b
  3. set a chmod to 777 to mksapkg-64b
  4. download the file test.sh and chmod it to 777 (just in case)
  5. go to plex website and download a file for OS3 and My Cloud EX2
  6. watch the video, it’s quite easy
  7. run the test.sh and wait for it to be done
  8. connect with ftp and download the file
  9. install it on your wdnas with OS3 using the methods from the first post

You can find the video file and everything else on https://wdnas.lampir.dev

So good people :slight_smile:

Thank you for the support these few years and I hope that I have helped a small number of people to have the latest version of plex. Since the new OS5 is supporting the plex out of the box, there is no need for me to repack the files anymore.

The link will still be active, but I will no repack them. You can use the archive and you can find the video I created on the website as well as the script for it.

Good luck with it :slight_smile:

https://wdnas.lampir.dev

What video?
(6. watch the video, it’s quite easy)
All i see are the files you mentioned and the instruction file.

Also will it work on Centos 8?