WD MyCloud EX2 Ultra recycle directories to recover deleted photos

I am trying to recover photos that suddenly disappeared from a share on my WD MyCloud EX2 Ultra. Last night my wife created a folder in her share on the MyCloud EX2 from her iPhone 6 which she renamed. She moved several image files into that share. I can see all this in the MyCloud App activities list on her phone. She deleted the photos from her phone and then permanently deleted them from the recently deleted folder on her iPhone. So they are gone from her phone. THis morning she couldn’t remember how she had done it and in trying to duplicate what she had done previoiusly she created several New Folders in her share. One of those she renamed and then moved some more photos into it from her iPhone camera roll. The extra New Folders created were deleted. All this we can see in the activities list of the WD MyCloud App on here iPhone 6. However we can no longer see the folder with the photos that she created the previous night. There is no record in the Activity List of having deleted that folder. I did a little research and found that there is recycle bin option for the shares on the MyCloud unfortunately it was not turned on for the shares. I also found a Recycle Bin option in the Settings group of the MyCloud control panel in the Services section.

My questions now are what is the difference between the share recycle bins and the recycle bin in the Control Panel settings group?

Is it possible that the missing folder and images files are in the Settings Group Recycle Bin?

I ssh’d into MyCloud EX2 /shares/Volume_1 directory and found a hidden directory named .!@#$recycle which I tried to open but the cd command complained with -sh: cd: can’t cd to .!@#.
I tried cd – .!@#$recycle and received the same error.

So where is the recycle bin and if what I found is it how can I open it to see if the missing photos are in it.

Finally, can anyone explain how the folder on the MyCloud disappeared and there is no record of it in the activity log?

Many Thanks,



I haven’t try that.

Let’s see if any of the users can share some information about it.

Had a similar problem today. I tried to rename a folder remotely from the browser and it simply gone in no time. Accessing from browser, iPhone or Mac finder it doesn’t show up. We have the Ex2 Ultra 4tb RAID for backing up our company files. How come? Have you found any solution?