WD MyCloud 4TB solid yellow light


I have a WD MyCloud 4TB and over the past week I have been unable to access the MyCloud. There has not been any changes with my broadband or network and now the MyCloud just shows a fixed yellow light. On the back of the MyCloud, the top Ethernet light flashes but the bottom one remains off. The MyCloud fan is on but there is no data transfer noise.

Hope you can help as all of my files are on this device.


1 Like

My Cloud fan? What specific My Cloud model do you have? The single bay My Cloud units do not have a fan.

Check the User Manual (if you haven’t already) for your My Cloud model to see what the front LED color means.

Can you access the My Cloud Dashboard (for the non My Cloud Home devices)?

Obvious troubleshooting steps. Power cycle all network devices one at a time. Change the ethernet cable used to connect the My Cloud to the router. Change to a different router port. Connect the My Cloud direct to the computer and see if it works.

Thanks for your reply.

There is a slight whirring noise so if there is no small fan then it will be the hard drive noise. Here is a summary of everything I have tried so far:
-Checked cables connected fine, inc ethernet and power.
-Replaced ethernet cable 3 times and still nothing different.
-Tried the 40 second reset a few times, including going over the time to ensure easily covering 40 secs.
-No dashboard access.
-No web access.
-Tried everything again using a friend’s router and still nothing except the solid yellow light on the front and only the top light of the ethernet port blinking every now and then.

Last memory of using the device was a couple of week ago when I was uploading a significant amount of pictures from MyCloud to Google Drive via the browser to start the process of backing up my files (I still had a huge amount of files to go and regrettably some are not backed-up). Due to the quantity of files, I Ieft my laptop on overnight for a few nights to do the transfer.

I’m at the stage now where I just need to get access to these files so do you mind helping me with these questions:

  1. Can I access the MyCloud through the USB port, or directly via another way?
  2. Can I access it through Ubuntu (linux) as I have seen on some forum’s?
  3. I am suspecting that the network port has failed rather than the device. Is there a way to replace the network port?
  4. Is there a way to take out the hard drive of the MyCloud and access it via a caddy?


1 Like

No. The My Cloud is a network attached storage device. The general way to access it is using a network connection. if one previously enabled SSH through the My Cloud Dashboard one could try seeing if the SSH connection works.

One can use Linux (Ubuntu or other Linux distro) to access the My Cloud hard drive when that hard drive is removed from the My Cloud enclosure and attached to either a spare SATA port or to a SATA enclosure.

If one is using Windows then see the following link which explains how to access a My Cloud drive when removed from it’s enclosure and attached to a Windows PC.

The problem is you don’t know if it’s the network port itself or something else on the motherboard backplane of the My Cloud. It might be possible to solder a new network port adapter in place but it would involve finding the exact same pinout network port and then soldering it in place after removing the existing network port.

Yes. See my answer to question 2. The internal hard drive of the My Cloud is a SATA drive. That drive can be attached to another SATA enclosure or to a spare SATA port on a computer. Note that opening up the My Cloud enclosure voids the device’s warranty.

If you do a internet search you’ll find a number of YouTube videos explaining various ways to open the My Cloud enclosure…

1 Like

Many thanks for your help Bennor.