WD MyBook 6tb fake

hello. i got a new mybook 6tb.
i’ve plugged it in then connect it to the pc and does not show up.
i’ve checked disk management and device manager and it doesn’t show up.
i’m running windows 10. the device detection doesn’t even pop up.
other usb external drives do.
i’ve tried plugging it on mac, on laptops and still not detected.
please help me.


Have you tried using a different USB cable an/or another computer if possible?

Also, make sure the drive is connected directly into a wall outlet in order to discard any power issues.

yes i did try another usb from the other working drives.
tried on 2 pc, imac, laptop.
and the power is plugged in directly. is the led light supposed to stay on?
or only turns on when the usb also is plugged?

i found out whats wrong. i tried everything and even changing power adapter it still didn’t work.
out of my frustration, i tried opening the book case - well thinking that i might just get another enclosure
or plug the hd directly inside the pc, but lo to my surprise and disgust…

it contained a very old maxtor 10.2gb with apple logo and red LOUD marking on it.
very surprising and disappointing.

what can i do? it’s been past 30 days since i purchased it from target. please help.

i sent this for rma last week. of course they don’t believe it.
this is my last purchase of wd products.