WD My Passport Ultra not recognized on Samsung TV

Hello All,

I am a new user for WD Hard Drives and recently ordered a Hard Drive - WD My Passport Ultra 1 TB
The Hard drive works properly on my laptop, but is not recognized by my Samsung TV.

I have tested changing the cable, which still does not solves the problem.
Also, I have tried formatting the hard drive (So as to Remove Password set on my HDD).

Please note that this does not seems to be a port 3.0 issue or cable issue or file format i.e. NTFS issue, the problem is something else as I have tried all the above 3 options and in either case my issue still stands unresolved.

On TV set, the name of the HDD comes but when I check the Information of device it shows 0.0 KB as Total space and 0.0 KB as Used space which is WIERD.

Any leads to help me fix this would be great !

Thanks in Advance :slight_smile:

could be a GPT Partition issue … some TV’s only support MBR

check your 1TB to see if it’ GPT, if it is … reformat/partition it NTFS / MBR