Wd my passport ultra not recognised by mac book pro


#1

Im currently using a macbookpro (retina 15 in 2014) os x el capitan version 10.11.6 and Ive had this wd my passport for a while but didnt really start using it until now since my computer is out of space. At first, I was just plugging it in and an icon would pop up on the desktop. I could click on it and it would open up in the finder and i could see when the last backup had occured. I noticed that it wasnt backing up tho because the last back up date didnt match with the last time i plugged in the drive. From what i believe the drive is set to automatically back up once i plug it in. So i went into the time machine and tried to just manually back up the files. I tried doing the back up but i kept getting a message saying it was unable to do so… also when i would try to exit out of this, it said it could potentially do something to the drive… Finally i just exited out the folder, ejected the drive and pulled it out of the computer. I tried plugging it back in but the icon that was showing once before was no longer popping up. the drive was spinning and the light was on tho. i even went on my disk utility but the drive wasnt even popping up on that. I really dont know much about this thing and its kind of confusing lol help please thanks


#2

Hello, Vajoiner1

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support