Macbook Pro does not recognise My Passport Ultra. (OS X 10.11.5)

It can be seen neither in Finder nor in Disk Utility. This has happened first time in my 1year of purchase. I tried connecting other external hard drives to the mac and it worked. I tried changing the usb for this present hard disk and it still does not show up. I can see a light that keeps on blinking but I am not sure if my mac reads it at the moment. I even tried attaching it to my LG tv and it asks to remove and connect again. NEED HELP!


If possible, test the unit on a different computer. If stills the same, please contact WD Support for additional assistance on your case.

WD contact info:

Cool I’ll try. Appreciate it. Thanks!

Hi! Rishabh_Shah I have the same problem! HELP ME PLEASE! :sob:

Had a weird problem with mine also with 11.5 When I used disk utility to format the drive, when it boots the drive would give me a “disk alignment error” so I tried formatting through WD Disk utility and the issue never returned… Weird.

Hi Kesier
My drive is unrecognised and a it makes a weird clicking sound.Can u please tell me if could use the drive after erasing using disk utility