WD My Passport Ultra Chromebook Compatability

Hello all,

I recently purchased a WD My Passport Ultra 1.5 TB. I Tried plugging it in to my Acer 11 Chromebook (2GB RAM, Intel Celeron) and it said it couldn’t recognize and needed to reformat. After trying to reformat it said an error occurred. I have contacted Google support, but they just took me through basic troubleshooting (power cycling and the such).

I reformatted the drive to both FAT32 and NFTS and tried connecting to my computer then with no luck. According to google, ChromeOS is compatible with both FAT32 and NFTS.
Source, under filesystems tab

tl;dr: Is the WD My Passport Ultra 1.5 TB compatible with ChromeOS, specifically the Acer 11 inch Chromebook.

Thanks for any help!

Hello,

I have never tried it on this computer but i see no reason why it shouldn’t work.
Have you tried on another computer to make sure it is not a drive issue? or, have you tried another drive on this computer?

I have tried the drive on a Mac and a desktop running Windows 7. Both work fine. My chromebook also recognizes the drive is connected, but I can’t transfer any files or format the drive.

Sent from Outlook Mobilehttps://aka.ms/blhgte

Hello,

It is possible the computer is not providing enough power to spin up the drive. Have you ever tried another portable drive on this computer?

I found out it was because my WD Passport had the security feature on it, which is an EXE, something ChromeOS cannot run. After removing the password the drive worked perfectly.

Are you using Windows 10? Ever since I upgraded my computers to Windows 10, I have experienced problems related to the WD My Passports and Elements that I own.

Please, WD, do something about this or I will abandon loyalty to you. This isn’t just Microsoft’s responsibility.

How did you remove the password?

1 Like

Had to use the security application that is installed with the drive on a windows computer before I could put it on a chromeOS

Thanks. Will try that.

Hi, how did you removed the password? thanks