WD My Passport Ultra 2TB slow reading

I have a WD My Passport Ultra 2TB. It is less than a year old and half full of files. It has been working fine until yesterday when I was transferring a file as usual to it and it stopped in the middle of it and ejected itself. When I re-connected it, it seemed to be responsive but was reading very slow and causing my macbook to do the colour wheel while it was loading the files. The files seem to be intact and I tried using another usb cable and other external hard drives but they were fine. I tried it on another macbook and windows computer and it had the same issue. It seems to be recognised by all the computers fine, and my files seem to all be there, but when I click on a folder, it takes up to a minute for them to open and when I try to open a file it takes another minute to open and doesn’t open correctly and causes the computer to freeze while it is loading. Is there any thing I can do to fix it or at least get the 950GB worth of data off of it?

Have you tried browsing online for a data recovery application?