WD My Passport (Mac) Slowing Down


#1

I am interested in seeing if anyone has discovered an issue with their 500GB PPort slowing down once reaching near 50% capacity. Copying music into iTunes has become truly laborious as I can no longer perform “mass dumps” (no crude jokes pls! lol). Instead, I am forced to drag/drop one song at a time…and as a DJ, that is just not efficient or effective.

I’m wondering if it is worth the time and effort to downsize my library…or if it is a product issue. Mind you, I currently run FW800 to transfer files…on a less than 2 month old, brand new MacBook Pro.

Holler if ya hear me!


#2

You should not experience issues when the drive capacity increases, this sounds like a file system limitation. Try checking if is formatted on FAT32 which is slower and can not transfer file larger than 4gb. You can convert the partition to HFS on your MAC.


#3

You’re seriously considering downsizing your library?  No.  Just no.  My advice is to reformat the drive and see if that helps- like the person above me suggested, make sure it’s in HFS+ (Mac OS Extended, Journaled).  Open up Disk Utility (press cmd-spacebar to search for it), select the drive, and click the Erase heading, then Erase.

Make sure you’ve got everything backed up at least once beforehand.  Drives are cheap!  Go get another one if you don’t have access to one already.  I hope you already have a backup of your music anyway- all hard drives fail, it’s only a question of when.


#4

I am having issues with my 500GB Passport slowing down as well. It’s less than a year old, I have it hooked up via firewire to my iMac.

I’m trying to copy a 32GB folder to my Passport and it is taking forever! It’s stating that it’s going to take 19 hours. I’ve tried copying it to a different hard drive that I currently have and it worked in 8 minutes.

So I copied everything off my Passport onto my other external drive which took about an hour (About 134GB). I formated my Passport using the Disc Utility. I made sure Mac OS Extended, Journaled was selected and I get the same problem. Copying any files to the Passport takes forever!

Thoughts?


#5

Run First Aid or another testing utility , it sounds like something is wrong with the drive.


#6

I ran First Aid on the drive and I ran the quick test through the WD software and both tests said that the drive was fine. I started doing a full test on it, but after an hour it never moved past 10% complete. I stopped the test and am now erasing the drive again using the WD software.

Ok connected now using USB cable and running the quick test.  Ok quick drive test passed. Going to attempt to copy the files again. It still states 9 hours to complete.

Running First Aid using disc utility again. This time the Verify Disc test is taking much longer, although I am connected via USB still. Volume appears to be OK. Going to shut down now and reboot with Firewire installed.