WD My Passport 500gb Essential Nightmare!

Hi all, 

Well it has been a journey of forums / and a multitude of different recovery / partition programs - and a journey which brings me here to see if the community can help.

Over Xmas I was transferring files and the operation stalled and provided a lot of error messages. My laptop froze and had to manually power down.

On restart the Passport essential froze my laptop, and since then has done the same each time I have tried using it.

I have tried using the drive in my work pc running Windows 7 - which will recognise the drive as “My Passport 0730”

However, every 5 minutes it keeps restarting the drive and popping up the message “Windows must format the drive”

I have run the following software;

Testdisk - No partition detected, Error reading all data

Easuse - It once detected that the drive used to be named “Edds Passport” however after one scan (which was constantly interrupted by windows insisting the drive must be foratted) it will not recognise the drive in full recovery. However if I use partition master it sees the drive as F: My Passport 0730 as NTFS - but only sees the file as RAW

HDtune - no go

HDD refenerator - no go

It was formatted originally as FAT32

I tried Chkdsk on Dos - said the format is RAW and cannot perform any task after.

I’m unable to see the drive in Computer Management  as it freezes all the time. Ejecting the drive is also a no go as it says it is always in use when I try to eject it safely.

Have tried another solution by uninstalling the drive in Device Manager but this also did nothing.

Is there anything else I can try? This drive has over 400GB of material I cannot afford to lose.

Thanks in advance

Hello Mate,

That’s not good at all, but there are several free softwares to help you;



Also check this article:


Thanks for that - have tried Test disk but no luck - will check the other 2 out.

If I find a way to format the disk, would I be able to recover any files?

Try booting from a Linux Live CD and see if you can access the data that way.