My Passport 500 gb not recognized

I bought a 500gb usb 3.0 my passport external hd couple of weeks ago. It worked fine for the first week. But now I’m having a strange problem.

Windows shows my drive as RAW and says it needs to be formatted to continue. If the drive remains connected, a new dialog pops up every few minutes saying that

You need to format the disk in drive F: before you can use it" with a button to format. But when I click the button, after 5 minutes a dialog opens up saying

" Windows can’t  format F.

Check to see that the disk and drive are connected properly, make sure that the disk is not read-only and then try again. For more information, search Help for read-only files and how to change them."

I’ve faced this problem before with my Toshiba drive and I used to run a data recovery software to recover data and then format the drive. I tried doing the same with my new WD one. But none of the data recovery softwares ( I tried Easus and mini tools one ) recognise the drive. 

I tried calling all the nos. listed for western digital support in India, but none of the numbers are correct. I also posted the same question in their support page but received no reply.

I would like to recover my data somewhow, if possible. But if it is not, I would like to format the hard drive and move on.

Please help. There was no password set on my drive, if it helps in any way.

I just posted an answer to this here


Nope. You provided the link to the minitools recovery software. I already tried that one and the Easus one too. Both do not detect the drive when plugged in.

I am facing the same issue. Were you able to recover your data or to format the disk?


Sorry try this link