WD My Cloud won't play/stream certain videos on TV

Hi,

Not overly technical so please be kind!
I have a WD My cloud which i use primarily for storing music to play on my Sonos system and storing videos and photos. Until recently, i haven’t really used them too often to view videos but recently bought a new Samsung Series 7 TV and wanted to use this feature.
Unfortunately, when i try to do this several of the videos are just not visible. If i access the videos on my laptop through my files etc. all videos are visible in the relevant folders and play just fine. There is the same issue when trying to play them on an ipad mini and on my previous TV through a PS4 or Blu ray player. I figured the issue was probably the older technology and that a new TV (which i was already buying would sort the issue).
Some details (trying to pre-empt questions):
Most of the videos are recorded on Samsung galaxy S7 or previous Galaxy versions. I have some videos recorded on an Akaso Brave 4 action camera and these play just fine.
The WD my cloud is connected to the router - all other devices are streaming from it via wi-fi.
I keep an external HD back-up of all content on the WD MC and if i plug this into the TV they all play just fine.
Is there a simple fix i’m not aware of? If not, if i bought a different NAS (e.g. Synology or any recommendations?) and copied everything across (there’s a lot of content) should this rectify the problem? (The WD MC is 4 years old so an upgrade wouldn’t be the end of the world if it meant it all worked).

Anyway, thanks in advance.
D
P.S. I have previously (old TV) tried re-scanning and re-setting everything (+ re-labelling the PS4 as blu-ray or something in Twonky - i don’t get all of this stuff, but did follow some advice, but to no avail).

The media file type would need to be supported by both the My Cloud and the media player app on the TV.

See the following WD Knowledgebase article which explains the supported media formats of the My Cloud.

If the problematic media files are confined to those videos recorded by the Samsung Galaxy then chances are the Samsung Galaxy recorded the video/audio using a “codec” the My Cloud cannot decode. The workaround is to use third party software to re-encode the media using a different media encoder or different media codec. For example, as a troubleshooting step one could try to reencode the video file using the free Handbrake program and see if the TV will play the media file.

https://handbrake.fr/

Ok, thanks. Assuming that the Samsung TV can play Samsung phone videos, the compatibility issue would be the WD MC - in this scenario a new NAS should sort it surely?

As dor re-encoding i wouldn’t know how to do this - is this just a case of all files being transferred or some software downloaded that then works on the TV or My cloud to do this as they play? How would i do this?
Cheers again

Don’t assume that a Samsung TV would play Samsung phone video. It all depends on how the video is recorded (and in what format) and what file types and format types the TV’s media player supports.

Generally all the media server in/on the My Cloud is doing is streaming the media file to the TV media client. It is up to the TV’s media client to properly play the media. If a video file, like MP4 for example, is encoded using an encoder that the TV media client doesn’t support then the file will typically not be playable on the TV.

As a test, download the Handbrake program from the link provided above. Open up one of the Samsung Galaxy video files in the Handbrake program. Select a Preset. Set the Format to MP4. Then select Start Encode and the Handbrake program will encode or transcode the video file into MP4. Once the Encode is finished, copy the newly created file back to the My Cloud and then access the TV and see if the newly created file can be played by the TV’s media client.

Ok, thanks again. I will try that, but that sounds like it would require me to do this on every single video - I have literally thousands.

Because the tv plays all of these fine from the external hd I keep coming back to the fact that the wd my cloud is the issue and that a solution is finding another nas (that will play the files)

If it is a codec issue then unfortunately one would have to convert all affected videos if they want to use the media server on the My Cloud.

The TV is using the DLNA protocol when accessing the My Cloud media server and most likely uses a different method/protocol when accessing a hard drive that is directly connected to the TV.