WD My cloud website not working

https://files.mycloud.com/login.php
Service is down despite that page is working.

Are you located in the United States or another country? Have you tried a different browser?

Country: Portugal.
Tried on a different computer/browser and in other network (home/work).

Greetings.

A mi me paa igual desde el Domingo pasado, y he revisado en foro ingles y hay tambien comentarios desde Alemania y desde Estados Unidos.
YO he proibado diferentes PC y diferentes navegadores y siempre da este errror

"El servidor ha encontrado un error inesperado que le ha impedido completar la solicitud. Cierre esta ventana y vuelva a iniciar sesión. "

Espero lo solucionen pronto

When will this be solved? ETA?

The same for me, trying to access from yesterday, have tried all the possible bowsers, cleaning cache, etc. and still haven’t manage to access it. And really needed to… This is really frustrating, have anyone of you heard from the staff? Is there any other way to access or is this an issue soon to be solved?

Same problem for me. I use Mac with Mojave and see the same error message. Doesn’t work with any browser.

I use the same exact system, but still no reply from them! :((

This is happening again. Different error but no access to My Cloud Web.
The link it returns its this: https://files.mycloud.com/index.php?error=true&brand=webfiles
And return back to the login page. Its always on this login page loop.

Is there a timeframe to fix this?