WD My Cloud unable to do anythng on the Dashboard

Hello. I have a new WD My Cloud 3TB device for Xmas. I have created an account with an administrator password.

I have managed to install everything on my laptop and have the shortcuts on the desktop (wd my cloud learning centre, wd my cloud, wd my cloud public share and wd my cloud dashboard).

I have the my cloud app on my Samsung Galaxy S5 and can access everything on my device from that app. I think I might have been unable to access it using the my cloud username (I had to use the e-mail address)

However, when I go to the My Cloud Dashboard on the laptop to try to do anything like add cloud access or add user etc. I just get a message saying ‘updating’…then nothing happens. I have tried leaving it to run for hours but nothing.On the ‘Settings’ tab the 'Cloud Access Remote Access is greyed out and set to ‘OFF’ and there is nothing displayed on te connection status.

I really am a bit lost. I think I mht have upgrade the firmware when I installed it on my laptop. The currrent firmware is v04.00.00-607.

I am using google chrome but tried it on IE as well, no differece. I suspect ot ould be the new firmware. Is there any way of going back to the old frmware or will I just need to do a full factory reset? Advice on back to factory setting swould be appreciated.

Hope someone can help. Thanks.

Here is a link to the latest Firmware if you want to install it. It should only take around 35 to 40 minutes to complete.


By opening the Dashboard>Settings>General>Cloud Access look at configure and see what choice is showing. See image below.

Posted by,
cat0w (USA)

Thanks for that. I will give it a try.

Update: The firmware deb couldn’t be installed - it kept cming up with an error. So I gave up and just switched the unit off at the main supply and left ot off for a couple of minutes and switched it back on. The unit rebooted and hey presto - the dashboard seems to be working OK now.

Firmware now WDMyCloud v04.00.00-607 : Core F/W. I suspect it was a firmware issue. 

I must say I have very little confidence in this now - the most basic installation has been a nightmare.

I am reluctant to upgrade the firmware as don’t want any more problems.