WD My Cloud Home stuck on flashing white light

Hi,

I recently moved home and plugged in my WD My Cloud Home, and it’s stuck on a fast flashing White light.

I cant connect to it via my pc or app, i’ve tried several ethernet cables and nothing works. I’ve tried turning it off and on and have pushed a pin into the reset hole for 60 seconds and longer. I cant get the light to stop flashing or reset, I’ve left it on for 24 hours in this state and it’s not changed. Can anyone please advise.

Hi iamtallaus,

You can refer the link provided below and provide us more information about the type of led light that you are getting on a My Cloud Home device.

https://support-en.wd.com/app/answers/detail/a_id/18042

Thanks. I have a strobe light on my WD My Cloud Home, I’m, using the power supply provided and have also a backup just in case, but neither have fixed the issue.

Hi iamtallaus,

We always recommend to connect the power supply directly on the wall socket and to keep back of your data on two different locations. If you have the backup of your data on a different location then you could perform the troubleshooting provided in the link mentioned below.

https://support-en.wd.com/app/answers/detail/a_id/5722

Hi, thanks for that message but none of those trouble shooting options work, I’ve held in the reset button for well over a minute and the strobeing light doesnt change at all.