The white light on My Cloud is constantly blinking

Three days ago I moved My Cloud to another part of my desk and the white light will not stop blinking. I have tried pressing the reset with the ethernet cable in and out. Pulled the power waited for a minute. I read on another thread that it is doing a file system check. Should it really take three days? This is frustrating. up until now, It has worked great since I got 10 months ago. I really need advice.

Per the WD My Cloud User Manual a blinking white LED:

  • Displays when you first apply power to the unit.
  • Reset pressed.

Because you moved the My Cloud I would check both ends of the Ethernet cable to ensure its properly inserted to both the router/gateway/hub/switch and the WD My Cloud.

Other things to try. Unplug the power adapter and plug it into another outlet/power strip to see if the error clears. Try performing a 4 second reset. Remove power from the My Cloud for 5 to 10 minutes then reapply power. Move the WD My Cloud back to its previous location and see if error clears. Try a different Ethernet cable.

Doesn’t that really need a bit more detail than worded? When my MC is first powered up, the white LED comes ON briefly then it blinks once then goes solid for a long period then blinks again and after another shorter period of time goes blue. That whole process is about three minutes.

My MC is on a power strip along with a Gigabit switch so there could be a slight difference as the network comes alive at the same time.

since installing new firmware (OS3) I am continually advised that myCloud has restarted, or that my network connection is intermittent.
Why is this happening?