WD My Cloud Data Recovery


#41

I forgot to mention that when sda4 is unmounted it might be impossible to browse all shares by SMB. So you could try using WinSCP to browse files by SSH.
About the screenshot, I think something went wrong. Try to check the log file (in another putty window command: nano ExtundeleteFullRestoreLog.txt). When the process is running you shouldn’t see another line for typing, that’s why I think it finished restoring too fast and something went wrong.


#42

Was unable to start another putty session. So typed on next line as per attached. May have to unplug cloud and external drive, re-initialise the cloud and replug the seagate. Then have a look at the folder on the seagate external drive.


#43

You could use a program called WinSCP to access files on My Cloud by SSH (something like putty but for files exploring). Then external drive should be accessible in /nfs/driveName.
It should be possible to start multiple putty sessions with no problem. Make sure you typed address/root username/password correctly.

If not enough files were restored, try to remove “–after NUMBER” from the restore command. Maybe it doesn’t know deletion time that’s why doesn’t restore it.


#44

I have been reading the log. Looks like the space has been reallocated. It was an accidental folder delete of several subdirectories comprising about 100 pics. It was the last delete and must the internal processes of the wdcloud that overwrote the space. Gone but not forgotten.

Thanks for all your help.


#45

That’s why it’s important to unmout partitions from writing access instantly after we detect data loss :frowning: You could try ext4magic as the last hope, with some command to restore that folder.


#46

And take backups…


#47

@cpt_paranoia if you read my case, I lost data when I was attempting to make a backup. So anything can happen, really.


#48

Well, you were mucking about with the drive before you tried to make a backup.

That’s a reminder for all of us: get the basics done before you start trying to ‘improve’ things.


#49

@cpt_paranoia what I’m trying to say is: I had weekly laptop drives backups, family photos stored on at least 4 drives and I still managed to lose some (thankfully not very important) data. So things like this happen, even to people who in general care about their data. That’s why data recovery knowledge is always something worth to learn. It’s hard to understand untill it happens to you (hopefully never, I don’t mean to wish bad things to anyone).


#50

I have read your case Mona as well as numerous others. WDCloud nas comes with its own back-up system that you must configure from the start. Me, like most, just want to get into backing up/storing data. After loading the drive I noticed that when deleting, it kept referring to permanent deletion for every file. WTF, no recycle bin!

I looked into it further and tried setting up the “time machine back-up” etc. After a ‘not enough room’ error and then tried to set it up on the external usb device. This also didn’t work and crashed the device. After rebooting the WD, I put it in the too hard basket until my accidental deletion.

I have since been lucky to recover 75 percent of my folder deletion using putty/unmount/extundelete as per all the instruction on this string of posts. I was also very lucky to find most of my original photos still in storage and can re-scan them bringing me back up to about 90 percent.

The critical key, as mentioned, is to turn the bloody machine off!. You leave it on and it will crunch away merrily with it own nas processes, and write over your deleted files. Only turn it on when you are ready to recover.

I consider myself lucky and thank everyone in this string for your help. I am sure we haven’t heard the end of this…note. Still can’t set the ‘wd recycle bin’. It crashes the device and won’t let me log in. So I am now removing data until I get this issue sorted…NTS…and everyone…Remember to backup!


#51

Hi Have been trying to restore some data on My Cloud.
plugged USB drive in to the drive with and typed the folllowing using Putty

I have done all the steps:

./extundelete2.4 --restore-all --after 1501538400 /dev/sda4 --log ExtundeleteFullRestoreLog.txt

keeps saying can not open file.

Any ideas?