WD My Cloud Blank Dashboard


#1

Hello everyone,

I just got my WD My Cloud 3TB and while setting it up through the dashboard it seems to have crashed and now all I am getting is a blank page when I am trying to acess the dashboard.

I have read some threads describing similar problems and also have tried resetting, 5sec and 40sec reset, with nothing changing. I also have tried 3 different browsers, just to make sure that the browser is not he problem.

I hope someone can help me, thanks in advance.


#2

#3

Thanks for the quick response, but I think were are not on the same page. When trying to access the dashboard I just get the blank page as I posted earlier. There is nothing to click, even the WD logo is not clickable.


#4

Couple of troubleshooting suggestions if you haven’t tried them already.
Try a different web browser.
Disable any browser add-on’s or browser extensions.
Disable any security/firewall software.
Try a different computer or mobile device.


#5

@SaiyaTrunX Is this what you own? WDMyCloudImage

Have you looked at the User Manual for your generation of My Cloud?

Have you tried this?

image