WD My Cloud 4TB - solid orange light - is my device bricked?

Hi,

I have been happily using my WD MyCloud 4TB since about Aug-2014.

I have not had any real problems, and have tentatively upgraded my drive to the lastest firmware on a number of occasions without issue.

However… I recently moved house and when doing that I unplugged the drive from my router for the first time in a long time.

The device was moved by me gently in my technology moving box with all my tech stuff, so not dropped or damaged in any way. At the new home, I setup my router, (FritzBox 7390, Firmware 6.53) and plugged in my WDMyCloud and have not been able to get to appear on my network since.

The device has been connected to LAN port 1, with gigabit ethernet.

At one point I was running a static IP address, but I cannot remember what state it was in prior to turning it off, the last backup file of the fritzbox shows it with a dynamic IP. But nothing has changed in the setup of the router so static or dynamic should have no impact as the setup has not changed.

This is what happens:

1. I plug in the power cord.
2. An Orange LED appears? 
3. It flashes off and back on once only and remains solid the rest of the entire time
4. Both Ethernet lights flash on to begin with, then the top LED stays on and flashes whilst the bottom LED goes off. The device never shows up with a valid IP address.
5. I leave it on an the light stays a solid orange, and it never registers with the router.

Is this an orange light? Its definitely not red, and would not call it yellow, it appears orange to me, I have asked a few people what colour would you call that and they have all said Orange?

I have tried the following trouble shooting as per the notes on the various support guides:

1. 4 second reset - Nothing appears to happen the light remains solid, no flashing LED, no ethernet activity
2. 40 Second reset - as above nothing happens
3. The frtizbox has the ability to control the speed of the port so, I have tried a Gigabit port and 100 Mbit port on the same port
4. I have tried connecting to different ports on the router, LAN4
5. I have tried using different ethernet cables.
6. I have tried a direct connection between PC to the device via local ethernet configured in DHCP, and the device is not showing up, arp -av
7. I have tried using a staticIP address on the PC in the range of my network in case the MyCloud had a static IP setup, no connection

So I am wondering what the next trouble shooting options are, is my device bricked, and is the only option for recovery to follow these steps

Thanks

Perhaps it would be best to send an E-mail to WD Support about this. You can do so in the following link:

Try to provide as many details as possible related to the issue at hand alongside everything you have tried so far. They may request additional information for troubleshooting.