WD my cloud broken? orange flashing light...HELP!

I have a WD My Cloud 4TB (code: wdbctl0040hwt), suddenly it has stopped working. It has an orange flashing light, and there is no network connection. I rebooted the drive several times, with no success. I tried to reset by holding the reset button and initially it worked, but few hours later has stopped working again, showing the orange flashing light.
What can I do? Is it broken? I have lost all my data?

EDIT: I can’t add replies to my post because my account is blocked (!). Anyway I tried a 40sec reset as manual suggests, but it didn’t work because the device is not rebooting or responding to any command. Moreover, there is nothing on manual about an orange flashing light. Really disappointed about this situation, maybe I will try to contact the support even if my WD is out of warranty ( I bought it on 2014)

The LED behavior is explained in the user manual on page 7. it could be one of the following reasons

Attention Red Blinking The following circumstances trigger this state:
• Disk thermal warning threshold exceeded (under or over temp)
• Ethernet cable not connected
Fault/action required Red Blinking The following faults trigger this state:
• Disk SMART failure
• Data volume does not exist
• System volume does not exist
• System thermal shutdown (75 C)

I would try a 40 second reset. Instructions are on page 91 of the UM. It will reset it to factory defaults. No data will be erased but it may help. If that does not solve the issue I would suggest contacting WD support directly.

Hi,
I created an account just to reply to this post.
Did you switch Ethernet cables?
I had the same issue and nothing seem to work, I thought I had accidentally damaged my device when I moved, but!
I luckily thought of checking my Ethernet cable, apparently I used a shorter cable in my new setup, and this cable was missing some internal wires… (think it was originally belonging to my philips hue bridge, but I ended up used a different cable for it)
I switched it out and everything started working fine again :slight_smile:
Try switching out the cable and see if that is the issue.