WD My Cloud 4GB And Windows 2012 Server Backup


Did anyone tried to make a windows backup from Windows 2012 Server on the WD My Cloud 4GB?

I have a weird situation here, all my backups fail with error “incorrect function” my drive has v03.04.01-230 firmware and i tried every available combination with user related authentication.

Windows server is fully update and are ok with other NAS and Local USB.


The error from the windows backup utility :

The backup operation that started at ‘‎2014‎-‎05‎-‎28T16:19:45.046622100Z’ has failed with following error code ‘0x807800C5’ (There was a failure in preparing the backup image of one of the volumes in the backup set.). Please review the event details for a solution, and then rerun the backup operation once the issue is resolved.

The detail log : 

+ System
- Provider
      [Name] Microsoft-Windows-Backup
      [Guid] {1DB28F2E-8F80-4027-8C5A-A11F7F10F62D}
  EventID 5
  Version 3
  Level 2
  Task 0
  Opcode 0
  Keywords 0x4000000000000000
- TimeCreated
      [SystemTime] 2014-05-28T16:20:08.141586800Z
  EventRecordID 13
- Execution
      [ProcessID] 660
      [ThreadID] 4160
  Channel Microsoft-Windows-Backup
  Computer WebSrv.xxxx.xxxx.xx
- Security
      [UserID] S-1-5-18
- EventData
    BackupTemplateID {A34C77E9-69FE-4ABE-8DE7-EDABE40F1C8E}
    HRESULT 0x807800c5
    DetailedHRESULT 0x80070001
    ErrorMessage %%2155348165
    BackupState 12
    BackupTime 2014-05-28T16:19:45.046622100Z
    BackupTarget \\olynas03\olympia
    NumOfVolumes 1
    VolumesInfo <VolumeInfo><VolumeInfoItem Name="C:" OriginalAccessPath="C:" State="12" HResult="-2147024895" DetailedHResult="0" PreviousState="9" IsCritical="1" IsIncremental="0" BlockLevel="1" HasFiles="0" HasSystemState="0" IsCompacted="0" IsPruned="0" IsRecreateVhd="0" FullBackupReason="2" DataTransferred="0" NumUnreadableBytes="0" TotalSize="0" TotalNoOfFiles="0" Flags="1544" BackupTypeDetermined="1" SSBTotalNoOfFiles="0" SSBTotalSizeOnDisk="0" /></VolumeInfo>
    SourceSnapStartTime 2014-05-28T16:19:45.030995800Z
    SourceSnapEndTime 2014-05-28T16:19:59.688280600Z
    PrepareBackupStartTime <TimesList><Time Time="2014-05-28T16:20:05.969Z" /></TimesList>
    PrepareBackupEndTime <TimesList><Time Time="2014-05-28T16:20:06.204Z" /></TimesList>
    BackupWriteStartTime <TimesList><Time Time="2014-05-28T16:20:06.204Z" /></TimesList>
    BackupWriteEndTime <TimesList><Time Time="1601-01-01T00:00:00.000Z" /></TimesList>
    TargetSnapStartTime 1601-01-01T00:00:00.000000000Z
    TargetSnapEndTime 1601-01-01T00:00:00.000000000Z
    DVDFormatStartTime <TimesList></TimesList>
    DVDFormatEndTime <TimesList></TimesList>
    MediaVerifyStartTime <TimesList></TimesList>
    MediaVerifyEndTime <TimesList></TimesList>
    BackupPreviousState 9
    ComponentStatus <ComponentStatus><ComponentStatusItem Name="9bebf4e4-d979-4146-b285-5b67b30646d5" LogicalPath="Microsoft Exchange Server\Microsoft Information Store\WEBSRV" Caption="Mailbox Database 1762072059" AppId="Exchange" WriterId="{76fe1ac4-15f7-4bcd-987e-8e1acb462fb7}" InstanceId="{03272abc-56b9-4365-bd4a-da38f10cc548}" ConsistencyCheckResult="0" ConsistencyCheckResultDetailed="0"/></ComponentStatus>
    ComponentInfo <ComponentInfo></ComponentInfo>
    SSBEnumerateStartTime 1601-01-01T00:00:00.000000000Z
    SSBEnumerateEndTime 1601-01-01T00:00:00.000000000Z
    SSBVhdCreationStartTime 1601-01-01T00:00:00.000000000Z
    SSBVhdCreationEndTime 1601-01-01T00:00:00.000000000Z
    SSBBackupStartTime 1601-01-01T00:00:00.000000000Z
    SSBBackupEndTime 1601-01-01T00:00:00.000000000Z
    SystemStateBackup <SystemState IsPresent="0" HResult="0" DetailedHResult="0" />
    BMR <BMR IsPresent="0" HResult="0" DetailedHResult="0" />
    VssFullBackup true
    UserInputBMR false
    UserInputSSB false
    BackupSuccessLogPath C:\Windows\Logs\WindowsServerBackup\Backup-28-05-2014_16-19-45.log
    BackupFailureLogPath C:\Windows\Logs\WindowsServerBackup\Backup_Error-28-05-2014_16-19-45.log
    EnumerateBackupStartTime <TimesList><Time Time="1601-01-01T00:00:00.000Z" /></TimesList>
    EnumerateBackupEndTime <TimesList><Time Time="1601-01-01T00:00:00.000Z" /></TimesList>
    PruneBackupStartTime <TimesList><Time Time="1601-01-01T00:00:00.000Z" /></TimesList>
    PruneBackupEndTime <TimesList><Time Time="1601-01-01T00:00:00.000Z" /></TimesList>
    BackupFlags 0x8
    ComponentInfoSummary <ComponentInfoSummary ComponentInfoArrayPresent="1" TotalComponents="0" SucceededComponents="0" />

and the very detailed log of M$ from C:\Windows\Logs\WindowsServerBackup\Backup_Error-28-05-2014_16-19-45.log file :mansurprised:

Backup of volume C: has failed. Incorrect function.


 Any thoughts?

Are you trying to create a backup or a system image?

The instructions on how to create a backup on Windows are on the following link:



I have the same problem with a 3TB MyCloud.

Did you find a solution meanwhile ?

Same Problem.

Server 2012 full patched.

WD my Cloud 2TB.

firmware:v04.00.00-607 (same problem with previously version)

Using WBAdmin via BatchFile to Backup the Server to a WD’ Share.

The same backup task works perfectly to other NAS or network share.


I have the same error.  WD please fix.

The solution for this problem (at least for Windows Server 2012) is to create an iScsi device on the My Cloud. Then use the iScsi application on Windows Server to connect to the iScsi share on the Mt Cloud. Then use Server disk manager to initiate and create a drive from the iScsi connection. I did this and it seemed to work fine. Here is the article:


Thanks IkoIko the link was really helpful