WD My Book - TV won't read contents of the drive

I just recently got a new 4TB My Book drive and after loading a ton of movies onto it I plugged it in to my Samsung TV and the TV is saying “no movie file in current device”

I tried updating the firmware on the drive and also on the TV to no avail

I also tried putting a plain movie file in the root of the drive so that there’s not just folders, that didn’t work either.

It’s a 4TB drive with an NTFS file system, does the drive HAVE to be a FAT32 or should it read with an NTFS file system?

Try posting in the TV section you’ll get more help. I don’t know if your TV will recognize a drive that large. Also it may need to be formatted FAT32

I’m running W7 and formatting as FAT32 wasnt an option. It was either NTFS or exFAT. So I reformatted as exFAT and still no change.

I like the idea that my tv won’t recognize a drive that big… not sure why that would make a difference though. Makes sense since my first drive was a 2TB and this is a 4TB.