WD My Book Studio II 4TB - can't see the drive, My Book makes clicking sound and flashes


I have WD My Book Studio II 4TB with lots of movies on it.Windows 7 Pro 64 bit

I usually connect it to PC when I need to add movies to it and turn it off correctly.

About a week ago I connect it and the drive didn’t load. Windows couldn’t see it.i tried reboot my PC,turned off and on my external drive, reconnect it from beginning but without any success

I tried even to pull out one of the drive to at least backup my movies on my pc.but the PC didn’t recognize drive alone.

So far,I can’t have access to my book at all - and before I send it to repair -is there any way to back up my data that’s on my book?

Can I take out both of the drive and try to connect them to the PC? Would it recognize them together?

Any advice would help

thank you

If you can hear a clicking sound is provable that one of the internal hard drives failed. If you had it on RAID 1 you can try connecting one of the internal hard drives directly to the computer motherboard and see if you can recover your data. If that doesn’t work, you might need to contact a professional data recovery company. 

1 Like