WD My Book Studio Edition II Has Ceased to Mount on my MacBook Pro

I’ve had my WD My Book Studio Edition II for about 2 years and until recently it almost always mounted on my computer screen. At first, the light went on but it began to mount slowly, then more slowly. Since this morning, the light has not come on, and it doesn’t mount.

I’m running Mac OSX Version 10.5.8 with a 2.4 GHz Intel Core 2 Duo. Memory is 4GB. The connection is via eSata cable.

I’ve tried the shut down the computer, unplug the My Book, switch computer back on, wait a few minutes, then plug the My Book back in method, but nothing happens.

I’ve zapped the PRAM on the computer. No result.

I’ve tried switching to different eSata cables. Nothing.

I’m not particularly technical, so if anyone has any suggestions, would be grateful if they are in simple, layman’s terms.



Are you able to try with a different connection like USB to test the unit?  Maybe a different computer as well.

Have been away, hence the late response.

Your suggestion that it may be the connecting cable that was at fault, was helpful.

The connecting eSata cable was plugged into an Addonics Port Multiplier. I tested the connection a couple of times with three different eSata cables, plugged directly into my Mac. Each time, the MyBook icon popped up on my monitor.

So it would appear that the Port Multipier is malfunctioning.