WD My Book Studio Failure


Our 750GB My Book Studio has seemed to spontaneously fail. The power to the HDD is on and all connections are solid, the white led light on the face is lit but is not moving like normal. I have tried to turn it off/on without success and have even unplugged it completely, letting it sit for several minutes before plugging it in again without change. At a loss as what to do. We use it solely for our iMac Time Machine backups. Any advice?

Thanks in advance,



Have you tried using a different USB Cable?

Make sure that the power adapter is connected directly to the wall outlet? 

Have you check on the disk utilities to see if the drive is showing?

See the following link for assistance on how to check if the drive is showing on disk utilities.



Thank you for your reply.

The HDD is pugged into a power protection device as is the computer. I have tried other recepticles on this unit as well as plugging the HDD directly into the wall to no avail. It seems the HDD is getting power, but this last time it was making a “ticking” noise, like something was stuck? Further the light on the front of the unit that goes up and down, ala Knightrider, is not moving and the HD is not “moving” or making any noise as it normally does when booting up or downloading info.

My drive has two firewire connections and one connection that looks like a mini usb. Not only do I not have a connection of that type I don’t know how to get it to one of the connections on my Mac.

The Drive does not show up on the desktop, like it normally does, nor does it show up on the Time Machine as a choice. The disk utility showed no hardware found on the Thunderbolt drive.