WD My Book Essential 3tb- Can only transfer files from cmd very slow transfer rate

I have an External WD My Book Essential 3tb that I was running a windows check disk with both options checked (fix file system errors, attempt recovery of bad sectors) during the process the check disk got hung up (ran overnight). I had to unplug the drive and restart the computer. Afterwards I would plug the usb in and the disk would not show, until after 5 minutes when it would come up as E:Local Disk instead of the usual E:My Book. Then after anout 15 minutes showing E:Local Disk, it would finally start showing as E:My Book with all of my files. However trying to access the files would make windows hang, and sometimes throw it back and forth from E:Local Disk to E:My Book.

I ran a chkdsk from cmd first checking for file errors /f and it found very few errors and said that it fixed them. I then ran chkdsk /r which it made it to step 4 and got hung up halfway through for hours. I had to abort the procedure. I then ran testdisk to check for partition problems or a problem with the mbr. Testdisk showed the partition 3 different times. So I chose the first one and tried to fix the partition with a write also the mbr with a write to. This did not fix my problem.

If I leave the drive plugged in long enough, it seems to start working and I can see all of my files. However, when I try to copy them to another drive the whole system freezes up and I cannot copy any files. So, I decided to try xcopy from command prompt copying all files from directory to another external drive. This works, but very slowly and I have 1.75tb of data to transfer which at the speed it is could take a month or more.

Questions I have, I can see my files, I know they are there. I can hear the disk spinning although I can also feel it somewhat “small jerk” every now and then. Should I possibly remove it from its encasement and hook it up internally?? I have heard that WD drives use encryption on their drives, so would that even be an option? Is there any chance that the slow speed and choppy access are from the usb connector?? Or is the drive going bad and I must take the slow route if I want to recover all of my files??

I have tried a lot of different options to remedy except taking it out of its case. I have tried to use: Acronis which freezes up when trying to access drive, Paragon- which also freezes. Tried, Easeus which does not allow me to choose the disk. I have hooked it up to multiple systems running different versions of windows (XP,Vista,7) all have the same outcome.

When testdisk was running an analyse cylinder (which was also running very very slow) is when I had the most access to the disk and actually had the flashing light go solid for awhile. But, again I had to abort the analyse cylinder because after 24hours it had not even gotten to 1%. But, that was only on one of the three partitions shown in testdisk. I really need some advice on this one- copying over my files with xcopy is working but will take probably a month to transfer…

Please help!!!

System: Windows 7, I5 pentium, 6g ram

One more thing, when I try to check the disk in disk management it freezes up, unless it is after the half hour load time for the disk. When it shows it shows disk as healthy active.

Thank you-


If you take the drive out of the enclosure and connect it to a computer it will be unreadable since the drive will be encrypted.

I recommend you try to copy the files to another location and then try to format it or write zeros to it.

You can also run a diagnostic using WD DLG.

I have run the quick test once before, and it failed at that time. However, that may have been before the disk actually mounted which it does after about a half hour time.

I have another drive exact same specs, I have seen that opening the case and cleaning the connectors (if dirty) sometimes works.

But, what I am really interested in knowing is if I can try and swap the USB board to see if that is the problem. After the disk actually mounts, I see all of my data and can check through different folders, I just cannot copy them to backup because it makes windows hang.

Also, in disk management the disk shows as healthy and active, are you sure there are no alternatives to retrieving my data??