WD Live TV won't turn on ?!

#1

Hello there,

I have the old model WD Live TV, here is a picture :

I haven’t used it for a while (probably months…), and it wasn’t even connected to its power supply too…

Few days ago I tried to turn it on. It didn’t work. I thought the remote control was dead, I changed the battery, didn’t work. I changed of remote control itself for 8€, fail again. I disconnected my USB hard drive from it, as well as the USB key. Still nothing. The power led doesn’t turn on at all. Zero signal. It’s not a queston of firmware, because I have never updated it…
I found a topic here about that kind of problem :

and the last message could be related to mine :

“But if I leave it untouched for an extended time, then it won’t turn back on from standby with the remote – I have to power cycle it.”

But I don’t know what does he mean by “I have to power cycle it”. I tried to connect and disconnect the power cable many times, but it didn’t help…

Does anyone here have a solution ? ( I’m almost sure the power supply is ok. )

#2

If the Power LED on the front on the WDTV is not turning on … then that’s got nothing to do with the remote control. (the WDTV when switched on at the wall socket will automatically power on without a remote control … it’ll do the same thing if there is a power blackout and when the power is restored it will automatically power on.)

If you’re sure the power supply is ok … then it could probably be electrolytic condensers that have leaked (which is very common in old electronics) and are now stuffed causing the WDTV not to power on.

Inside …

And if any of them have a domed top (not flat) or look like this … then that’s the problem
blown_cap

#3

arf… I was expecting that answer … :confused:

I’ll see how to open the case and check the condensers

#4

Ok case open…
And everything is in perfect condition, no dust, condensers are 100% clean… !

I bought a new power supply, that’s the last option, I’ll be back for a status update