Wd hd tv live gen3 hangs and wont start movie

Hallo out there!..

i have had my wd hd tv live player for a while now and everythink has worked just fine, but lately it starte to give me some problems.

Firmaware version: 1.14.09

when i start a movie it just hangs and the arrow just keep going in circles over and over and nothings happens.

when i factory reset the device i can watch one movie and when i select a new one same problem.

iam streaming from my NAS via windows share.

Please Help!



This seems to be an issue that quite a few people, including myself, are having. I hope it gets resolved soon.

is it after the latest firmware ?

I have three different boxes and this problem started happening on two boxes with the most recent firmware updates. One of my boxes had the very old firmware 1.03.10 and it was working perfectly fine, but it is acting up on the newest firmware (1.14.09). I’ve tried installing all of the firmwares on my box and I still get the same issue. I doubt it is my server because I can play the movies fine if I play them with my laptop (connected via a network cable too). It seems we are not the only people having this issue, so I’m leaning towards it being a firmware bug. Whatever the case, I hope a solution is found soon. If you try rolling back your firmware let us know what you find. :slight_smile:

i have the exact same problem, when i click the files on my laptop it starts instantly. but when i use my wd hd tv live nothing happens…

hope WD are aware of this problem and will make a hotfix VERY soon!

THere is a section on these forums where you can report the issue. Someone has reported this issue, but to let WD know that this is hapenning quite a bit you have to give kudos to that post, which is like saying… “this is happening to me too”. Here is the link to that section so you can give kudos to the post describing our problem. http://community.wdc.com/t5/WD-TV-Live-Streaming-Issue/idb-p/streaming_issues

MKVToolnix 5.9.0 introduced new elements “cue duration” and “cue relative position” which provide more detailed information for seeking. This might throw off some hardware players. Remux your files with 5.8.0 and see if that makes a difference. I’ve stayed on this version and so far all my MKVs run just fine.

Skal i have to remux all my files no way! WD have to fix this problem very soon or els I’m looking for a new player!

So how do you expect WD to fix your problem if you can’t be bothered to remux ONE file to try if this even is the cause?

just tryed remux it 5.8 and same **bleep**!

why dont WD test there firmware before they deploy it!

Because they can’t test all crappy files people throw at their WDs? All my MKVs play back just fine without doing a factory reset.

its thair jobs to test it out before deploy, they just turned my wd hd tv live into a brick!

Correct and someone said same about Divx/Xvid a while ago in threads I was reading when I bought this **bleep** at Xmas time.

Sure its old but it should work fully inc FF/RW as its old and tested and works perfect in software players on a PC and has done for 10+years.

There is a few peeps here who claim to have no issues but for some sad reason hang out the forum and have high post counts telling others they are doing it wrong/user error etc.

I can tell you for a fact if I had zero issues I would not be here, must have sad lifes or on WD payroll. :wink:


do you have same problem ?

No, he’s only got a problem with reality. You know, like accepting the fact that problems often enough stem from the user side, e.g. when people download web**bleep** and expect their hardware player to compensate for the scene’s ineptitude or when they whine about slow firmware downloads while everyone else has no problems downloading them at top speed. Or the fact that if the bugs were really that omnipresent as claimed, a much higher percentage of WDTV owners would complain here rather than a vocal minority.

But if you’re so sure it’s the player and not your files, why don’t you upload one and let us try to play them back on our players?


The wired thing is that it has worked on the exact same files for long and I have watched all the movies on the WD TV LIVE and now I can’t play them on it.!?

That’s what’s weirding me out too but as long as we can’t try your files, there’s not much to do. Some people even reported that rolling back to a previous firmware would not allow them to play their old files either. It just doesn’t make any sense.

However, you say it happens over windows share, so it’s possible something on your network changed? What happens when you try to play the very same files from USB and/or roll back to 1.13.18 and do a reset in between?

i have now tried to rollback to 1.13 firmware, and same result i can watch one movie and then it just wont start the others movies not matter what i do.

its like when i play a movie the wd tv wont close the player, when i press back it keeps going in the background i can hear the movie when in the main menu, when i so go back to the movie playing the arrow come and star going in circles over and over and i cant do anything.

Just found a another work a round, pull the power cord for 30sec and boot it back up then i can play one movie.!

Wonder if its a problem with it don’t clear its built in cache!?

There is a bug that when pressing STOP, the file’s audio will continue playing for a few moments while already back in the filebrowser. Now you say, you’re pressing BACK. What if you press STOP when you finished watching a movie? I mean, I’m watching uncompressed BD rips, so with that kinda bitrate the cache/buffer should be filled too.