WD Green 2TB Internal HDD in Disk Management, Format attempts failed

Hello, I recently bought a WD AV-GP WD20EURX 2TB IntelliPower 64MB Cache SATA 6.0Gb/s 3.5" Internal Hard Drive and am currently having trouble formatting it. I understand that anything bigger than 2TB won’t format as MBR, so I went ahead and tried that, nothing. I figured I’d outline everything I’ve done so I don’t get any confusion.

First off,

Computer doesn’t see the HDD, Disk management does as RAW.

Delete/New volume has been tried multiple times.

Usually, I would try to format it, and immediately it would tell me that the format was unsuccessful.

Using CMD to do all of the above has also shown no success.

Now, I tried formatting (not quick format), process takes forever (usually bringing hope to see the progress % going up) but at 100%, turns out unsuccessful. I am trying to format this HDD as NTFS and put windows 7 on it Need help terribly, willing to use teamviewer and respond asap other specs:

Motherboard: http://www.asrock.com/mb/Intel/Z68%20Extreme3%20Gen3/

WD HDD: http://www.newegg.com/Product/Product.aspx?Item=N82E16822236603

OS: Windows 7 Ultimate

At the moment, I’m using another HDD to work off of while this one is plugged in as well Please let me know if you need screenshots of any sort or any more information

Lag in reading and writing