WD Elements SE - WDBEPK0020BK - Drive Disappears from My Computer

I ordered this drive through Amazon.com.
The drive originally would not show up in Explorer.
I found the drive in Disk Management, Formatted it and it will show up in Explorer for a few minutes, then disappears.
I tried copying a large amount of data (~250GB) to the drive and it errored out in the middle of the transfer. Saying the location was not available. It showed that it had copied a few gigs of data. When I unplug and replug in the drive it shows up. However the data that I copied was not there.
I copied a smaller amount of data ~100 MB and it seems to be staying put.
I tried again and got a different error code. “An unexpected error is keeping you from copying the file. If you continue to receive this error, you can use the error code to search for help with this problem. Error 0x80070037. The specified network resource or device is no longer available.”
Unplugging and replugging in the drive showed that ~500MB got transferred before the drive unmounted itself.
How do I fix this?


You might want to try Microsoft Help for the error code you reciieved.