WD Elements Portable 1TB USB 3.0 External Hard Drive


I bought the WD External hard drive about a month back. The first few times I used, it worked fine albeit a bit on the slow side which I put down to my laptop not having a 3.0 port. Since then it’s pretty much become unusable. Whenever I try to transfer anything from hard drive, it starts off fine for a few seconds and then completely freezes. That’s then followed by my entire laptop lagging and ultimately I’ve to restart the laptop. Any attempt to press ‘cancel’ on the "Copying xyz file’ dialog box only worsens the lag and doesn’t get rid of it.

The size of the file doesn’t seem to make any diference because the behaviour remains same whether I’m transferring a 5gb folder or a small 100mb file. There’s still about 700gb free space on the external hard disk.

My Laptop has a gb ram and an i3 processor.

Help would be greatly welcome.

Welcome to the Community.

I’d suggest testing the hard drive for errors. This behavior is not normal.


If your hard drive passes the test the next step would be updating all USB controller drivers on your system and replacing the USB cable.

1 Like

Hmm…I did that test (Just the Quick test) and this time the data transferred without any issues. Not sure how just a test could resolve the issue but I’m not complaining.

Thanks for the help.

Try a different USB cable no longer than the original and don’t connect through a hub.



 I have same problems and you. tried solutions that you mentioned but with no luck. it still not working. Tried using another cable but its still not working 

 what should be my next step? my hard drive is in warranty still. should i send it back?