WD 1Tb Elements transfer rate extremely slow

I had this for over a year a now, without any issue but last week after copying some things to hard drive, it’s transfer rate has dropped to 0MB/s. Basically, I always keep a 100g free on my hard until last week I had to help transfer some stuff to a friend. After copying those stuff I had about 90gig free space but when we tried to copy back, the hard drive didn’t show up in explorer at first. But, somehow messing around with it and switching ports finally worked. But, we cannot copy anything from the hard disk because of the slow transfer rate. You cant even play movies from it because of the slow speed.  So far I have tried, WD Data Lifeguard and HD tune too but none of it worked.  DLGDIAG fails  half way with the error  “Quick Test on drive 2 did not complete!” “Status code=07(Failed read test element, failure Checkpoint =105 (Unknown Test)”  

HDtune on the other hand does not even show the temperature it also fail halfway with a “Read Error! Test aborted”. Minimum transfer rate is at 0.0 MB.sec abd Max transf is at 114.5 MB/Sec.  On the other hand, CHKDSK fail at stage 2 with the error "A snapshot error occured while scanning this drive. You can try again, but if the problem persists, run an offline scan and fix.

 Is there anyway to copy the things on the hard drive? Right now I can browse through the hard disk without any problem, though some times it takes a while to load if the folder contains video files. However, whenever I try copying it to local drive, the speed starts from 60MB/s but  quickly drops to 0MB/s and stays the same.



Have you tried using the drive on a different computer or a different USB cable?

If still’s having the same issue, please contact WD Support for further assistance on this case.

WD Contact info:


I have exactly the same problem. 2TD WD Passport Ultra. Worked OK for a month. Now transfer of Data is 150KB/Second…YES. 150KB/Second.

Have swapped USB ports, Have checked correct cable. Windows 7 64Bit. My five Seagate drives have worked seamlessly.

FYI have tried this WD Passport Ultra 2TB on my other Windows 7. Same slow speed. There is about 1 TB of data on the 2 TB Passport Ultra