WD Elements Portable 1TB black doesn't show up

Basically, when I bought the drive, I reformatted it (NTFS), deleting the pre-written files in the drvie (which includes the autorun etc.) Then I proceeded to back-up some of my data from the computer (Windows 8.1) to the drive. 

The following morning when I started my PC, the drive _ was not recognized. _ When it was connected, _ its light still glowed and the disk platters were spinning, _ so no doubt they were working. However, they didn’t show in the “This PC” part. I also tried to go to Device Manager and refreshed it and/or rescanned the disks, but it still didn’t show up.

I went to my main desktop and opened it there. For once, it worked quite well. I immediately backed up my data to another external hard drive (My Passport model [you can really see I’m a loyal person to WD]), and tried to connect my faulty drive to my first PC.

The light still glowed and the disks still spinned, but it was not recognized. When I put it back to my main desktop, it was not recognized anymore.

This disk is REALLY brand new (Just a day old at the time of writing) so I’m particularly disappointed with WD, or my computers, whichever the case. 

BTW, I also tried connecting my WD Elements Portable hard drive to my MacBook Air; it still didn’t show.

Any help would be greatly appreciated. I think I might return this to the shop.


Are you able to test the drive with a different cable?

It’s not normal to receive a defective unit as all the drive  are tested before the ships out of our warehouse to any reseller.

Also can you please check if the drive is showing on disk managment.

How to access Disk Management in Windows XP, Vista, 7 or 8 to manage hard drives